Ctrl + Tab doesn't switch documents



  • Hi everybod,

    Ctrl + Tab to switch open documents doesn’t work for me. I checked keybord settings. It shows Ctrl+Tab for next document and Ctrl+Shift+Tab for previous document. Keyboard diaglo doesn’t show any conflicts.

    Othen shortcuts e.g Ctrl+n for new page work without any issue.

    What am I missing?

    Best regards,
    Albert



  • From your description, I cannot tell. “It works for me”: Ctrl+Tab and Ctrl+Shift+Tab properly switch between the tabbed documents.

    I am using ? > Debug Info > Copy debug info into clipboard:

    Notepad++ v7.8.4   (64-bit)
    Build time : Jan 29 2020 - 01:31:03
    Path : C:\usr\local\apps\notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit) 
    OS Version : 1903
    OS Build : 18362.592
    Plugins : ComparePlugin.dll LuaScript.dll MarkdownViewerPlusPlus.dll mimeTools.dll NppConsole.dll NppConverter.dll NppEditorConfig.dll NppExec.dll NppExport.dll NppFTP.dll PreviewHTML.dll PythonScript.dll QuickText.dll XMLTools.dll 
    

    It may be that you have a plugin that has hijacked the Ctrl+Tab sequence without telling the Settings > Shortcut Mapper that it has done so (so that Shortcut Mapper doesn’t know to tell you that there’s a conflict). Or it may be that you have another application (like AutoHotKey) that remaps that sequence.

    You might try using Settings > Shortcut Mapper to change the keyboard shortcut to something else, and see if it works; if it does, then it’s likely something in your system hijacking Ctrl+Tab; if it doesn’t, then something might be weird about your instance of Notepad++. Let us know your results (including the Debug Info like I showed above), and we might be able give some next-steps.



  • Thanks to your comment I found the culprit. It’s “Multi PuTTY Manager”. If I close it Ctrl+Tab in Notepad++ works as desired. By the way Multi PuTTY Manager" also blocks Ctrl+Tab in Firefox.
    Thanks for helping!


Log in to reply