UDL Breaks



  • I’m having a nuisance issue with my UDL for Stata do-files. While I’m making modifications to the code the highlighting will occasionally show everything as if there is an open quotation or comment somewhere in the code. It fixes when I refresh the UDL so it’s not an actual code issue and is easy to resolve but it happens frequently enough that it’s a real pain. It’s also not repeatable, or at least if there’s a pattern/trigger I can’t figure out what it is.

    Any idea how I might fix the issue/anyone else have this problem with their UDLs? I found one post from 2018 without a resolution that appears to be similar, but it has limited information:
    https://community.notepad-plus-plus.org/topic/16332/highlighting-breaks/2

    Also I tried to attach the UDL export .xml to this post but it didn’t appear to work. Let me know how I can share that if you want it and any more info I should provide since this is my first forum post.
    Thanks :)

    Notepad debug Info:

    Notepad++ v7.8.5   (64-bit)
    Build time : Mar  4 2020 - 11:08:34
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Home (64-bit) 
    OS Version : 1909
    OS Build : 18363.720
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll 
    


  • I rarely work with udls but when I do I haven’t discovered such an issue.
    In order to be able to help identifying the cause of the issue a
    minimal example in addition to the udl is needed.
    If you can’t attach it here, use something like pastebin and link to it.



  • @Dan-Dewey said,

    Also I tried to attach the UDL export .xml

    @Ekopalypse replied

    If you can’t attach it here, use something like pastebin and link to it.

    The forum doesn’t do attachments (only embedded images). However, you can just paste in the text of your .xml, select that pasted section, and hit the </> button on the toolbar

    Or, if you prefer manually formatting your post, type two lines of ```, and paste the XML between, like,

    ```
    <NotepadPlus>
        <UserLang name="STL" ext="stl" udlVersion="2.1">
    ...
        </UserLang>
    </NotepadPlus>
    ```
    

    which will render as

    <NotepadPlus>
        <UserLang name="STL" ext="stl" udlVersion="2.1">
    ...
        </UserLang>
    </NotepadPlus>
    


  • The UDL file was too many characters to add as code so I used pastebin as suggested:
    https://pastebin.com/embed_js/GBCr8tW7

    I’ll post a screenshot next time it happens since as I said, I can’t seem to replicate it with consistency.



  • This post is deleted!


  • It happened again so attached are images of:
    the state after the syntax highlighting breaks
    after_issue.jpg
    the state after refreshing the UDL via the language dropdown
    after_refresh.jpg
    the state the code was before the highlighting broke
    before_issue.jpg

    When I make the same modifications again it doesn’t break so it’s not consistent. This was also the very first change I made after opening the file so that might be relevant.

    As a note, that highlighting is as if there is a left quote without matching right quote. However, there isn’t any left quote in the prior code, much less without a matching right quote.

    I had longer snippets from the beginning of the code initially however I work with sensitive information and although it was probably okay I’d rather not risk it.


Log in to reply