Can't set notepad++ as default program in Windows 10???



  • I used to be able to right click->open with->more apps->look for another app on this pc->find notepad++ in correct directory.

    I noticed that this stopped working recently when I changed computers and had to reinstall everything. Was this another convoluted update for Windows 10?

    Any workaround?





  • Hello,@Tony-Wang-0

    Please follow this step ,To set notepad++ as default program in Windows 10

    step 1 :- Run Notepad++ as administrator.
    step 2 :- Go to Settings > Preferences > File Association.
    step 3 :- Select Notepad “.txt” in Supported extensions panel.
    step 4 :- Click the "-> " to move it to Registered extensions panel.
    step 5 :- Close and try to reassociate.

    I hope this information will be usefull for you.
    Thank you.



  • @Prahlad-Makwana4145 thanks, but this doesn’t work for me. When I click Choose a Default, the only programs that shows up are Notepad and Wordpad, along with option to look for an app in the MS store.

    There is a Notepad++ in the app store, but it is not the official version.

    Seems almost like MS isn’t recognizing it as a possible default app, even though it’s clearly installed and visible under Apps&Features.



  • @Tony-Wang-0 ,

    If you have a 64-bit Notepad++ installed in C:\Program Files\Notepad++, search your registry for C:\Program Files (x86)\Notepad++ and replace any such instance with C:\Program Files\Notepad++ – it may be that something wrote the wrong value into the registry (maybe a previous 32-bit installation), and so Windows 10 looks for a nonexistent location, cannot find it, and then refuses to associate an OpenWith action for Notepad++.

    (I’d do a full search of the registry, but I think it’s something like HKCU\Software\Classes\Applications\notepad++.exe and/or HKLM\Software\Classes\Applications\Notepad++.exe, both of which might map to HKCR\Applications\Notepad++.exe. From what I remember, each extension gets an OpenWithList which includes notepad++.exe, and then the registry looks in Applications\Notepad++.exe to find out the actual path to that command; so if that key points to a non-existent executable, Windows ignores that OpenWith option. And I have a memory that something occasionally goes wrong and leaves the x86 version in the registry, even after the 64-bit is installed.)



  • @PeterJones thanks, this sounded so promising, but alas, doesn’t seem to be the problem.

    I even uninstalled (revounistaller) and reinstalled, no change. Also tried the 32 bit version, same problem.

    Now I’m really scratching my head because it sounds like it’s just my system, not some crummy Windows change :-(



  • Solution of @Prahlad-Makwana4145 does work for me under Windows 10 with 32-bit version of Notepad++, however with following addition.

    After setting file associations in Notepad++, go to Explorer again, right-click the file, “Properties” -> “Open with:” -> “Change” – now you can select Notepad++ and set is default.



  • had the same issue as @Tony-Wang-0 when migrating to new laptop; had already done @Prahlad-Makwana4145 's solution of adding the extensions inside of npp and still windows would open .txt’s in [not-npp]. Finally tried @adams13x13’s method of finding any .txt file, right click > properties > opens with > select another app on this PC and was able to navigate to npp.exe inside of program files and it looks to be working for all .txt now.



  • You can make it easier: add notepad++ as a debugger to the standard notepad. It goes something like this, works everywhere, and is supported by notepad++ itself:

    reg add "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\notepad.exe" /v "Debugger" /t REG_SZ /d "\"%You_full_path_to_dir_Notepad_pp%\notepad++.exe\" -notepadStyleCmdline -z" /f
    

    The quotes in the string are escaped with a slash to get inside the value and allow to work normally with long paths and non-standard characters in the names.

    To get the behavior back - just delete this key in registry:

    reg delete "HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\notepad.exe" /v "Debugger" /f
    

Log in to reply