Cannot save change of "Remember current session for next lauch"



  • When I checked “Remember current session for next lauch” and “Enable session snapshot and periodic backup” on, it seems working well on current session. Because it still checked on when I reviewed “Settings=>Perferences=>Backup” and there will be new backup files being created in “%AppData%\Notepad++\backup”.

    But the tabs when I closed last session will not be reopened every time when I restart the NPP and the settings of backup will be unchecked. I tryed to opening NPP as Administrator but it still not working.

    Is there any solution for this issuse?

    Notepad++ v7.8.5   (64-bit)
    Build time : Mar  4 2020 - 11:08:34
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Education (64-bit) 
    OS Version : 1809
    OS Build : 17763.1098
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll 
    
    


  • @Yang-Sigmond

    I assume that you are using multiple instances of npp at the same time, correct?

    If so, be aware that the last instance you close is the one which sets the
    session parameters.



  • @Ekopalypse Thank you for answering. But I’ve only opened one instance.



  • @Yang-Sigmond

    could it be that you have configured other programs to use
    npp as its editor?



  • @Ekopalypse Thanks again. I’m afraid I didn’t do that either.



  • Ok, to summarize.

    … will not be reopened every time when I restart the NPP and the settings …

    I get, that sometime it is working and then suddenly it stops working, right?

    You only use one running instance always and that Npp is not started from other programs, correct?

    Could it be that the config files get deleted at some point?
    Because of using some software like CCleaner?



  • This post is deleted!


  • Must : Setting -> Preferences -> Multi-instance -> Default: Mono-Instance

    if Multi-instance it’ll be such like that

    config,xml must be assuredly saved in such setting by closing Notepad++ with click close X , not alt-F4 nor a abrupt kill on Notepad++


Log in to reply