Double Click in find results does not open and highlight



  • In the past either running Macros or cntrl+shit+f for find in files, then double clicking on find result would open the file in a tab and highlight the exact find result. The was in consistent in the past working and not working, but not cannot get it to work.
    This very help when reviewing multiple log files.

    Notepad++ v7.8.5 (64-bit)
    Build time : Mar 4 2020 - 11:08:34
    Path : C:\Users\310237620\Desktop\notepaddplus\notepad++.exe
    Admin mode : OFF or ON
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 1809
    OS Build : 17763.1098
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll



  • @joemir3

    So if I understand you correctly your problem is that
    a double click in the “find result” window does not open the file
    and highlight the searched word anymore, correct?
    If so, this is still working for me.

    Notepad++ v7.8.5   (64-bit)
    Build time : Mar  3 2020 - 17:39:56
    Path : D:\...\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 7 Professional (64-bit) 
    OS Build : 7601.24544
    Plugins : ... 
    

    What you can give it a try is to
    stop all npp instances
    rename the config.xml from C:\Users\310237620\Desktop\notepaddplus
    and start npp.
    A new fresh default config.xml will be created on startup,
    means also previous changes are lost.



  • @Ekopalypse
    Thank you for the reply -
    I did what you suggested with no success.
    I did just upgrade to 7.8.6.
    Interesting observations it does work as expected if I do not use macros. If I remove the “shortcuts” file with self made macros it does not work.
    Once I add the macros, the find results from these macros do not open the file.
    If I remove the file with the self made macros restart npp… all work as expected.



  • @joemir3 said in Double Click in find results does not open and highlight:

    Interesting observations it does work as expected if I do not use macros. If I remove the “shortcuts” file with self made macros it DOES work.



  • @joemir3

    Could it be that the shortcuts file has been corrupted?
    If you open it within npp do see it gets colored correctly?
    If you can, install XML Tools plugin then you can check
    if this is still a valid xml or not.



  • @Ekopalypse
    It is something to do with the macros. If I remove all I created it works as expected by doing a find in files search with regex.
    The macro is using regex to find specific patterns in a pre-determined directory.
    The example below I created is “collisions”. The macro is cntl-shift-f for find in files with the regex and all works as expect, finds the pattern and display in a pop-up “find in files” results- BUT a double click on a result does not open the file.

    <NotepadPlus>
    <InternalCommands />
    <Macros>
    <Macro name=“Trim Trailing Space and Save” Ctrl=“no” Alt=“yes” Shift=“yes” Key=“83”>
    <Action type=“2” message=“0” wParam=“42024” lParam=“0” sParam="" />
    <Action type=“2” message=“0” wParam=“41006” lParam=“0” sParam="" />
    </Macro>
    <Macro name=“Collisions” Ctrl=“no” Alt=“no” Shift=“no” Key=“0”>
    <Action type=“3” message=“1700” wParam=“0” lParam=“0” sParam="" />
    <Action type=“3” message=“1601” wParam=“0” lParam=“0” sParam="\d+[^0]\scollisions," />
    <Action type=“3” message=“1625” wParam=“0” lParam=“2” sParam="" />
    <Action type=“3” message=“1653” wParam=“0” lParam=“0” sParam=“C:\NW-Review” />
    <Action type=“3” message=“1652” wParam=“0” lParam=“0” sParam="." />
    <Action type=“3” message=“1702” wParam=“0” lParam=“32” sParam="" />
    <Action type=“3” message=“1701” wParam=“0” lParam=“1656” sParam="" />
    </Macro>
    </Macros>
    <UserDefinedCommands>
    <Command name=“Get PHP help” Ctrl=“no” Alt=“yes” Shift=“no” Key=“112”>http://www.php.net/$(CURRENT_WORD)</Command>
    <Command name=“Wikipedia Search” Ctrl=“no” Alt=“yes” Shift=“no” Key=“114”>https://en.wikipedia.org/wiki/Special:Search?search=$(CURRENT_WORD)</Command>
    <Command name=“Open file in another instance” Ctrl=“no” Alt=“yes” Shift=“no” Key=“117”>$(NPP_FULL_FILE_PATH) $(CURRENT_WORD) -nosession -multiInst</Command>
    </UserDefinedCommands>
    <PluginCommands />
    <ScintillaKeys />
    </NotepadPlus>



  • @joemir3

    From xml point of view I don’t see an issue.
    Your data do have and instead of "
    but I assume those have been changed while posting.
    Can you double check?



  • @Ekopalypse
    When creating the macro, I do not use any quote or other characters.
    Just using this \d+[^0]\scollisions,.
    Steps I used to create the macro is the following.
    Macro - start recording
    cntrl-shift-f
    \d+[^0]\scollisions,
    then hit find all
    stop recording macro
    save current recorded macro.



  • @joemir3

    I see, but your posting contains those “html” double quotes and your shortcuts.xml should contain only real
    double quotes. Is this the case?
    Or asked the other way around, did you ever edited shortcuts.xml by hand?



  • @Ekopalypse
    When creating the Macros I used the steps above only and no editing by hand.



  • I copied your macro, restarted Npp and did some tests and
    those worked for me. Sorry, not sure what breaks it on your side.


Log in to reply