Trouble with Windows XP

  • When I run notepad++ (latest version) on XP in a VM, it works fine, but when run it on XP on bare metal I get an access violation and notepad++ quits. I need to use XP for a dev environment so I’m stuck with XP. Does anybody have an idea what would cause this?

  • @AR1972 said in Trouble with Windows XP:

    I get an access violation and notepad++ quits.

    NPP 7.5.1 I believe is the last version supported on the Windows XP platform. I’m trying to find the proof of that, currently only an old posting elsewhere in this forum.

    As to why it is working under a VM, well I’d say you’re lucky.


  • I found more evidence of the dropping of Winxp support here:

    That seems to be as much as I can find.


  • Thanks, I tried 7.3.3 and I get “unknown exception” twice but NPP runs anyway. NPP runs fine on 3 diff XP VM’s on 3 diff platforms, but fails on 2 diff bare metal machines, installed from the same ISO. Puzzling, maybe some more updates need to come in.

  • Hello @ar1972,

    Personally, I have several portable N++ configurations, with my professional Win XP 5.1.2600 SP3 - 32 bits OS, on an old NEC Versa M350 laptop, which I had to re-install, two years ago, from a CD, due to an hard-disk crash :-((

    However, I never had any Access violation problem nor any Unknown exception problem, both, before of after this re-install operation ;-))

    Presently, I’m working with the 7.8.5 version, but no trouble with the latest v7.8.6 version, too !

    Notepad++ v7.8.5   (32-bit)
    Build time : Mar  4 2020 - 11:04:20
    Path : D:\@@\785\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Microsoft Windows XP (32-bit) 
    OS Build : 2600.0
    Plugins : BetterMultiSelection.dll ChangedLines.dll ComparePlus.dll DSpellCheck.dll ElasticTabstops.dll Explorer.dll mimeTools.dll NppConverter.dll NppExport.dll NppPluginDemo.dll NppQCP.dll PythonScript.dll SurroundSelection.dll 

    Best Regards


  • These are both Pentium III machines, could it be the Pentium III doesn’t support some instructions generated by the compiler used to build notepad++.

  • Well, some time later I have reviewed and the versa 350 has pentium M processor, my very old device is also a Pentium III and got the same errors that ARI1972’s. I assume the VM are installed in a more recent hardware then they support the machine instructions that fail in P-III hardware. I use the version of NP++ that gives me the two exception errors but it works anyway. I’ll continue using my p-III until the device gets a “no-more” condition.

Log in to reply