Notepad++ v7.8.7 released



  • @donho
    Under v7.8.6 (32-bit) I can’t reproduce it, not with new files, not with *.txt.



  • In v7.8.7, with type = “normal text file”, it depends on what extension I type whether Notepad++ auto-appends the .txt extension or not.

    With the same file (just File > New, then type blah as the file contents), Save As results in:

    • type new 1.txt => actual new 1.txt
    • type new 1.ged => actual new 1.ged.txt
    • type new 1.ext => actual new 1.ext
    • type new 1.fon => actual new 1.fon
    • type new 1.blech => actual new 1.blech.txt

    Looking in HKCR in my registry, what it seems to be for me is that if the extension (.txt, .fon, .ext) happens to be in the HKCR keys list, then Notepad++ lets me keep that extension. If the extension (.ged, .blech) is not in the HKCR keys list, then Notepad++ auto-appends the .txt after the extension I typed.

    If I set Language > B > Batch, so it wants to default as .bat:

    • type new 1 => actual new 1.bat
    • type new 1.ext => actual new 1.ext
    • type new 1.fon => actual new 1.fon
    • type new 1.ged => actual new 1.ged.bat
    • type new 1.blech => actual new 1.blech.bat
    • type new 1.a => actual new 1.a (.a is in HKCR)
    • type new 1.aa => actual new 1.aa.bat (.aa is not in HKCR)

    edit: Conclusion: Notepad++ Save As (and similar) let you keep the typed extension if the extension is listed in keys of HKCR in the registry



  • Regarding the column selection for TAB position regression, here’s the way to reproduce it:
    Just add a valid url link like
    http://foo
    then this bug can be reproduced.
    Tested with v7.8.6 so it’s an old regression :)

    I’m working on it.



  • @PeterJones said in Notepad++ v7.8.7 released:

    edit: Conclusion: Notepad++ Save As (and similar) let you keep the typed extension if the extension is listed in keys of HKCR in the registry

    YES - that seems to be correct so this may NOT be a bug / regression, but a limitation of Windows Save As dialogue. Trying your test with Notepad.exe (Windows supplied, not the far more capable Notepad++ we’re fond of) demonstrates the same behavior - with my example “mygedfile.ged” gets saved from Windows Notepad.exe as “mygedfile.ged.txt” unless I surround the file name with double quotes or select “All types (*.*)” from the “Save As Type” drop down.

    I’ll amend the bug report 8398 to reflect this.

    Cheers.



  • @donho
    Yes, with an url I can reproduce it too in v7.8.6, but only with the option “Clickable link settings” enabled (which I have disabled normally).



  • Just tested with v6.6.6 (13th Friday edition) :
    Without URL it works as expected. With URL it doesn’t work - the behaviour is not the same (even more buggy).
    So it’s not a regression definitely, but a (Scintilla?) bug for sure.
    Could someone open this issue on Github please ?



  • Could someone open this issue on Github please ?

    I will do so. I just wait a few minutes to avoid opening the issue multiple times.



  • Done - 8400.



  • Thank you @Ekopalypse for opening issue. This bug has been fixed and will be in the next release.

    Regarding the filter problem, it’s not a bug to me, please check:
    https://community.notepad-plus-plus.org/topic/19536/gedcom-file-extension-ged/8



  • @donho said in Notepad++ v7.8.7 released:

    it’s not a bug to me, please check:

    (also reference: https://community.notepad-plus-plus.org/topic/19536/gedcom-file-extension-ged/9)

    I tend to agree now that @PeterJones has showed us the registry HKCR and file extension experiment and I get the same behavior when saving with Windows standard plain old boring notepad.exe. This appears to be Windows default behavior, not a Notepad++ “bug”.

    However, there is some discussion on the issue I opened prior to fully understanding @PeterJones troubleshooting and explanation. You may want to close that?

    Thanks for Notepad++! - and sorry about the premature bug report.

    Cheers.



  • @donho said in Notepad++ v7.8.7 released:

    Thank you @Ekopalypse for opening issue. This bug has been fixed and will be in the next release.

    I wonder if this is related?

    In 7.8.6 - no plugins and use external scripting to set:

    editor->setMultiPaste(1);
    editor->autoCSetMulti( $SC_MULTIAUTOC{SC_MULTIAUTOC_EACH} );
    

    When I type:

    test.c_str()
    
    new
    new
    

    And then do multiselect across the end of new and start typing .c_str():

    10e528a0-530d-4ba3-b5e2-7c0c9ff6fe92-image.png

    Upon pressing Tab or Enter, it autocomplete both and puts the cursor at the end:

    ac764df4-9cfa-4f6b-b00d-b5bb765fbcc4-image.png

    BUT, with 7.8.7 no plugins and setting the same with external scripting, after pressing the Tab or Enter I get:

    89b3cd4b-1cb5-40ad-b8de-5e4b93605f9f-image.png

    The cursor does NOT move to the end. Much like the column mode Tab bug discussed above. Does the same “fix”, fix this as well, or is this a different issue?

    Cheers.



  • @Michael-Vincent
    @donho

    I just answered my own question by learning to download your AppVeyor intermediate builds. YES, this is related and is FIXED by the same “bug fix”, - commit 6602840.

    Cheers.



  • For some reason when I click move to other view, instead of moving the text view to the other side, it moves all the other tabs to the other side. Does anyone have any info on this?

    I am using 7.8.7 (64bit)
    the 6.9 version I had before did not have this problem.



  • @Jason-Iqbal

    there are two views, view0 and view1 and it looks like all
    of your files were in view1. Now if you move a file to the other view,
    which would be view0, then it looks like you moved the other files
    as it arranged the views to be view0 on the left and view1 on the right.

    To replicate what I’m talking about.

    • Open npp - no files should be open except the automatically created new1
    • create another new file and move this to the other view
    • close new1 file
    • create multiple other files and move one of them to the other view.


  • Hi,

    I noticed a difference in how styling is applied to clickable links in 7.8.7, but I don’t consider it a “fix” as it seems rather unintended to me.

    This is how a link appears to me in 7.8.6 with a Style based on “Deep Black” (which doesn’t support “URL hovered” customization):
    old.png
    As you can see, the “Foreground colour” is applied to the text and underline of the link.

    This is how a link appears to me in 7.8.7 with the same Style:
    new.png

    As you can see, the “Foreground colour” is applied to the text, but no longer to the underline of the link.



  • @Noctum28
    Maybe THIS is of interest to you?



  • @Alan-Kilborn
    Yes, thank you.



  • @Ekopalypse
    Yes that is it. if I open several files then send one to the other view it sends all the other files to the otherside, after that it switches it normally. It must just be a design decision or something.



  • @Jason-Iqbal said in Notepad++ v7.8.7 released:

    It must just be a design decision or something.

    It might have been an unintentional design decision, i.e., it just happened.

    I’d much rather see, if there is only one view open, that that view is always the “main view” and never possible to be the “sub view” (these are terms the source code uses to describe them).

    Thus, if the user closes the last tab open in the “main view”, all of the tabs in the “sub view” should be moved over to the main. This is just my opinion and maybe there are some holes in wanting this that I haven’t foreseen. :-)



  • @donho

    There is a backward direction option disappeared in Find option after updating v7.8.7/Backward.JPG

    Please refer to the screen shot.

    Thanks!


Log in to reply