The link for Open User Defined language Folder... does not work



  • The link for language/User Defined language/Open User Defined language Folder… does not work
    I click on it and nothing happens.

    ======Version information ============
    Notepad++ v7.8.6 (32-bit)
    Build time : Apr 21 2020 - 15:17:06
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 1909
    OS Build : 18363.720
    Plugins : BracketsCheck.dll ComparePlugin.dll CustomLineNumbers.dll docMonitor.unicode.dll DSpellCheck.dll Explorer.dll HexEditor.dll JSMinNPP.dll mimeTools.dll MultiClipboard.dll NotepadStarterPlugin.dll NppConverter.dll NppExport.dll NppFavorites.dll NPPJSONViewer.dll NppPluginDemo.dll NppPluginTemplate.dll NppSaveAsAdmin.dll NppTextFX.dll NppXmlTreeviewPlugin.dll SpellChecker.dll TakeNotes.dll XMLTools.dll _CustomizeToolbar.dll



  • @Douglas-Kaynor-0 ,

    It works for me in v7.8.6 and now v7.8.7.

    You aren’t in local config mode, so it should be using the AppData folder or the cloud. Do you have cloud settings enabled (Settings > Preferences > Cloud).

    If not cloud mode, can you open Windows Explorer, and type %AppData%\Notepad++ into the explorer bar, does that folder exist? if so, is there a userDefineLangs subfolder?

    if yes cloud mode, can you navigate Windows Explorer to the folder set in the preferences? and does it have userDefineLangs subfolder?



  • My path to the “User Defined language Folder…” is C:\Users\dkaynor\AppData\Roaming\Notepad++\userDefineLangs
    There is a file in the above folder. The cloud radio button was enabled and set to C:\Users\dkaynor\OneDrive. Once I set it to No Cloud the link works. I checked my OneDrive folder and there are several Notepad++ files in it.



  • @Douglas-Kaynor-0 said in The link for Open User Defined language Folder... does not work:

    My path to the “User Defined language Folder…” is C:\Users\dkaynor\AppData\Roaming\Notepad++\userDefineLangs
    There is a file in the above folder. The cloud radio button was enabled and set to C:\Users\dkaynor\OneDrive. Once I set it to No Cloud the link works. I checked my OneDrive folder and there are several Notepad++ files in it.

    Thanks.

    When I set a v7.8.6-32bit to not use local config, enabling cloud to a dummy “cloud” folder (not really a cloud folder), it populates that folder with the main config files, but not a userDefineLangs folder. If I create \path\to\cloud\userDefineLangs folder and put in the default markdown UDL in that folder and re-run, it does not include the markdown UDL in Notepad++ and the Open User Defined Language Folder… does nothing (doesn’t open the folder).

    It looks like you’ve found a bug.

    Please file a bug report as described in this FAQ, and paste a link to your issue in this thread.

    Thank you.



  • Issue 8394




Log in to reply