Forced Extension



  • The latest versions are forcing an extension. The option to not use an extension changed and is not working any more. I have had to regress to an older version as I rarely use extensions. I hope this will be repaired in the future. The newest versions have eliminated the option in “Default Directory” to select “without file extension”.



  • @Frank-Posa

    see here for your solution.



  • @Frank-Posa ,

    Since v7.8.7, even the new-style applies an extension based on the selected file type in the save/save-as dialog. If you type no extension, it will take the first extension from the Save as type box:
    d4585943-5e2b-4801-9c57-a82459467aef-image.png

    Knowing that typing your own extension (like blah.ext) will override the auto-extension, I tried a trick of typing blah. to try to convince it to use an empty extension: as shown in the screenshot above, it still appended .txt to the filename, making it blah..txt, which isn’t what I wanted. However, if you then change Save as type to All types (*.*), and don’t type an extension, it will save the file with no extension.
    bd742425-f9dc-495f-b454-321fa4f5af73-image.png
    It’s a little extra work, but that will enable you to save a file with no extension. (Alternately, change your workflow slightly: create the file in Windows Explorer with no extension, then right click and open-with Notepad++ or drag the file into the open Notepad++.)

    Unfortunately, we’re finding that no matter how the save-options are defined, someone will think that NPP has done it completely wrong and not given the option they want.


Log in to reply