Bullet point and Multi-Asterisk not working as delimiters



  • Hi, I have been trying to create a UDL that makes the view a bit more colorful like in org-mode.
    In the delimiter section i defined * as a delimiter. But if i do that then ** *** **** delimiters etc. all take the properties of the * delimiter. Nesting does not help. Am i doing something wrong here or is this just how it works?

    Also i tried using the bullet point (that we get by pressing Alt+Num7) as a delimiter. UDL didn’t recognize or U+2022 as a delimiter but it recognizes it if put as a keyword. Is there any way i can make it or any other such special characters work as delimiters?



  • This post is deleted!


  • @phenomenal11 said in Bullet point and Multi-Asterisk not working as delimiters:

    In the delimiter section i defined * as a delimiter. But if i do that then ** *** **** delimiters etc. all take the properties of the * delimiter.

    Ok i figured this part out. So basically **** delimiter needs to defined first then *** then ** then * only then each of them will have different properties. Meaning you have start defining them backwards. Don’t know the technical reasons behind it though. Attaching a screenshot for more clarity.
    Still can’t figure out how to make the bullets work though. Any help would be appreciated!!

    UDL.jpg



  • @phenomenal11

    The reason why you need to specify ** before * is that the
    lexer walks through the delimiter one by one and if it finds one that
    matches then it ignores the rest.
    But I don’t understand what isn’t working at the moment.
    Maybe another screenshot will help clarify this as well?



  • @Ekopalypse
    Hi, I’m currently on mobile so can’t share the npp screenshot right now but what’s not working is the special characters that we get by pressing Alt+Numpad Keys. For e.g. pressing Alt+Num7 will print a bullet point. So i tried using this bullet point as a delimiter. But it just won’t work. It doesn’t take the styling i set for it. What’s weird is the same bullet point gets recognised as a keyword.



  • @phenomenal11 ,

    Note that @moon6969 had a similar complaint at the beginning of June: delimiters and operators do not accept unicode (https://community.notepad-plus-plus.org/topic/19498/udl-operators-unicode-support/). But, as you pointed out, keywords will accept them.

    There’s nothing we can do in the forum to fix that. I don’t know if there’s already an issue at https://github.com/notepad-plus-plus/notepad-plus-plus/issues – if not, you might want to add one, as described in the FAQ (https://community.notepad-plus-plus.org/topic/15741/faq-desk-feature-request-or-bug-report). BTW: if you do submit a feature request, I recommend to not bother mentioning the Alt+Num7-style nomenclature – it doesn’t add much to the issue, and might confuse them, thinking that you are having trouble entering the characters: what’s important is that we just want the ability to have generic Unicode in any of the UDL fields – folding, keywords, comments, numbers, operators, and delimiters – not just in keywords.

    Getting a feature request from an average user rather than one of the forum (or github) regulars carries more weight in the developer’s eyes. So please, submit that request (or chime into a previous request if it already exists – it’s considered polite to look for an existing request before submitting a new one). But, unfortunately, when you search the issues page for UDL, you will see there is a long list of open feature requests and bug reports for the UDL feature, so I make no guarantees that UDL will get any substantive fixes anytime soon.



  • @PeterJones
    Well i raised a request on github page. I hope it gets some interest from the dev.


Log in to reply