Copy as path puts last file first in a pasted list



  • I was wondering why (and how to not have this happen) Notepad++ puts the last file in a Copy as path first when you past in a list of files from a Windows Explorer.

    Eaxmple:

    File 1
    File 2
    File 3

    If I select all of the files, 1-3, and holding the shift key choose Copy as path and then past them into Notepad++ it will past them as follows:

    File 3
    File 1
    File 2

    Is there any way for this NOT to happen? Or a setting that can stop this?

    MC



  • @Michael-Charney said in Copy as path puts last file first in a pasted list:

    …paste in a list of files from a Windows Explorer

    You’ve named the culprit.
    In case you don’t understand: Explorer puts the stuff in the clipboard.

    Pasting into Notepad++ has nothing to do with Notepad++. It just blindly receives whatever is there.

    You can always sort the lines in Notepad++ after the paste, but depending upon what you are doing, the sort may not give you the ordering you seek either.

    Is there any way for this NOT to happen? Or a setting that can stop this?

    Not really.
    Nope, not a Notepad++ setting.



  • Hi @Michael-Charney

    Try to select all files in reverse order. For example, if I want to get the files ordered as 1-3, I select first the 3, then the 2 and finally the 1. These will be copied in Notepad++ in order 1-3.

    Tested and worked in my Windows 7.

    Take care.


Log in to reply