UDL, lost all formatting



  • hello, i have a UDL i created which i have been using for over 2 weeks now.

    today i can still see the option to select my UDL and even have my Keywords, Delimiters, Comments, etc in the UDL dialog box BUT all the formatting went to the standard default black. i even try to import the most recent copy, it bring in all the keywords etc. BUT no formatting (text colors, size, etc etc)

    any idea? i dont play with any settings or plugins… i assumed importing would get it back to normal, but it hasnt… any help? thanks



  • @JR said in UDL, lost all formatting:

    i dont play with any settings or plugins

    Is it possible that Notepad++ has been updated. Since you say you don’t change any settings the “auto-update” is probably selected. See under Preferences, then MISC. If there is a tick in the "auto-updater box then check to see if you can determine if it did update. This will only activate when you are running/using Notepad++, hence you should see the “update” information box.

    Terry



  • @Terry-R yes it has Enable Notepad++ auto-updater checked.

    why would updating NP break the formatting? but i have v7.8.7 says June 5 2020. but website has v7.8.9 as current version…

    are you saying i should update or that updating broke it and i need to manual reconfig on every update . thanks



  • @JR said in UDL, lost all formatting:

    why would updating NP break the formatting?

    I’m not saying that updating will break the UDL you created, but it has been known to happen that an update has broken something. The updating process does go through a testing phase and if no-one finds any faults then an “update task” is triggered and when your installation next checks (I think it’s a 2 week or so cycle) and sees a new version it will notify you.

    In your instance though it appears you haven’t updated at all, is that correct? Whenever something like your situation occurs you need to check for any changes that might have occurred. My idea was just one. If you can discount that then you need to look elsewhere.

    Possibly you might have one of more corrupt files in your installation, or did you possibly update/edit the UDL the last time it worked?

    Terry



  • @Terry-R thanks (doesnt look like i updated… there are 2 more updates avail from my current V)

    i have about 10 different formatting options in my UDL so i definetly didnt change everyone to default black. wouldnt my import return all the keyword
    AND formatting? it doesnt. just the keywords no formatting



  • @JR ,

    When you look at the status bar at the bottom of Notepad++ when you have this file open that you think should be formatted from your UDL, does the bottom left say “User Defined language file - XXXX” (where XXXX is the name of your UDL)? If not, then the UDL lexer isn’t properly selected for the active file. If the UDL isn’t selected, it’s not going to format your text for you.

    If that’s the case, then you can manually go to the Language menu, go below the horizontal bar near the bottom, and select your UDL. Does the highlighting appear?

    I am guessing you are either editing a file with no extension, so Notepad++ has no way of automatically knowing that the file should be associated with your UDL, or that the Language > User Defined Language > Define Your Language…'s Ext: entry for your XXXX UDL doesn’t have an entry to match the extension of your file.



  • i fixed it manually. i noticed my installation has a userDefinedLang folder which contains the default Markup language settings in an XML file, but I also have a separate userDefinedLang XML file which contains my customized languages.

    once i fixed it i can see the settings in the XML file i also made a copy on network drive and can see the same formatting in that XML as well.

    not sure how i lost the other one but at least i know how to troubleshoot if it happens again.

    thanks for the attention


Log in to reply