Old Pythonscript stopped working

  • @V-S-Rawat said in Old Pythonscript stopped working:

    seems I have to first uninstall previous pythonscript, and then reinstall 1.5.4.

    Yes. That is why I specifically said,

    I would highly recommend you un-install the v3.0.3 Alpha version, restart, then use Plugins Admin to install the latest v1.5.4 full-release.

    Note the words “I would highly recommend you un-install the v3.0.3 Alpha version”. That was meant to indicate that you uninstall the v3.0.3 before trying to install the v1.5.4. Apparently, that wasn’t clear enough.

  • @PeterJones


    I uninstalled and reinstalled pythonscript, this time directly through plugin admin, it installed v1.5.4

    Then I ran my script on my text, and the script is working again.

    Thank God.

    Now, I am freezing my pythonscript plugin to 1.5.4 and will not update it ever, untill it stops working for some future npp.



  • @PeterJones said in Old Pythonscript stopped working:

    The “Releases” on the right (which turns blue when you hover, indicating it’s a link) takes you to the releases page, with all the alpha and permanent releases.
    The “Latest” link in the green takes you to just the latest release, v1.5.4.

    I stand corrected.
    Perhaps I’m alone in this, but I’m more used to github showing a “releases” button/link up across the top of such pages, and not on the right; but truly, Peter is correct, and it is there.

  • @Alan-Kilborn said in Old Pythonscript stopped working:

    Perhaps I’m alone in this, but I’m more used to github showing a “releases” button/link up across the top of such pages

    That’s a recent change. I think I originally opted into the “feature preview” that made the UI slightly more “modern”, but moved the releases/most-recent links to the harder-to-find location, so I got used to it. But it appears that’s no longer a “feature preview”, and may have been pushed to everyone.

  • So that readers here know: @V-S-Rawat submitted a feature request on https://github.com/bruderstein/PythonScript/issues/155 to add the github URL to the PythonScript About dialog: I agree with that. I also added in the same request that they either get the old sourceforge pages updated to direct people back to the github for newer revisions, or that they remove the sourceforge links from the github page altogether, as it causes nothing but confusion.

  • Hello, @v-s-rawat, @peterjones, @Alan-kilborn and All,


    Of course, I understand that you may easily assign a shortcut, using a Python script for such a task !

    But, personally, you could use the simple regex S/R below :

    SEARCH [\x{200B}-\x{200D}\x{2060}]


    Moreover, you may also record this specific S/R in a macro ! Insert these lines, below, in the Macros node of your active shortcut.xml configuration file

            <Macro name="Zero Width Format Characters" Ctrl="no" Alt="no" Shift="no" Key="0">
                <Action type="3" message="1700" wParam="0" lParam="0" sParam="" />
                <Action type="3" message="1601" wParam="0" lParam="0" sParam="[\x{200B}-\x{200D}\x{2060}]" />
                <Action type="3" message="1625" wParam="0" lParam="2" sParam="" />
                <Action type="3" message="1602" wParam="0" lParam="0" sParam="" />
                <Action type="3" message="1702" wParam="0" lParam="768" sParam="" />
                <Action type="3" message="1701" wParam="0" lParam="1609" sParam="" />

    To see a representation of these zero-width format characters, use the Mark feature, and the regex :

    SEARCH [\x{200B}-\x{200D}\x{2060}]

    against the text, below :

    -----> <-----	0020	0020	SP		SPACE
    ----->​<-----	200B	8203	ZWSP	ZERO WIDTH SPACE
    ----->‍<-----	200C	8204	ZWNJ	ZERO WIDTH NON-JOINER
    ----->‌<-----	200D	8205	ZWJ		ZERO WIDTH JOINER
    ----->⁠<-----	2060	8288	WJ		WORD JOINER

    Strangely, depending of the current font used, in N++ :

    • The zero width space wrongly looks like a normal space character or like a thin space character

    • The word joiner character is wrongly seen as a true character, with a glyph representation

    On my system, only the PMingLiU and Symbola_Monospacified fonts show, as expected, 4 zero-width characters !

    Refer to the link, below, for additional information :


    Best Regards


  • @guy038

    dear sir,

    my issue is: How do I know what has stopped with each update of npp/ pythonscript/ python?

    How many of us dutifully every word of release note each of hundreds of software/ plugins/ addons/ drivers that we are using on our pc.

    When we have installed something and seen it working once, we wish and believe that it will be forward compatible and will continue working in future updates of any component of it.

    AND, if it doesn’t work, we should be notified somehow that it will not work any more, so that we check what has stopped working and how to correct it.

    There is the irresponsible work of a developer.

    If something has stopped working in a ps update, we don’t come to know that it has stopped working, and there is no message and we believe that it has worked behind the screen as earlier.

    That is what is wrong. If some previous syntax has stopped working, python and/ or pythonscript developers should throw a syntax error for that right there in the first run, so that the user at least gets to know that it is not working any more, then the user either learn the new syntax and edit his script to work with the new update, or the user can revert to previous update to keep his old script working.

    I think it is a mistake of pythonscript developers that they have allowed the old syntax as valid even when it is not working.

    I think that is what alpha beta testings are for.

    So I guess ps developers should give a thought to this.



  • @guy038

    npp shortcuts themselves are not a easy task. Such a simple thing is made so complex in npp. If we need to copy a shortcut to a new one and make a few changes to create another shortcut doing something else, that is not easy and probably just impossible, it is rather easy to go through entire charade of recording a new shortcut from scratch.

    You can compare how easy a MS-word macro is to copy and modify, and how complicated is a npp shortcut to copy and modify.

    I had planned to learn pythonscript as that opens a wide range of possibilities to create various MS-word like macros to do various things. It has far more flexibility.

    Thus, I learnt and made this first pythonscript and it started working, then I lost steam about learning pytonscript, and got busy in other things. Human mind is not so eager to learn new things at age of 60 years.

    so, when ps is available as a allrounder option, I would like to use that, instead of using a npp shortcut.

    Though I indeed have created half a dozen npp shortcuts that I have to use several times almost daily.



  • @V-S-Rawat said in Old Pythonscript stopped working:

    I think that is what alpha beta testings are for.

    You installed alpha software which didn’t work for you, and are now complaining that the PythonScript developer didn’t alpha test enough?! Think about what you just said!

  • @PeterJones said in Old Pythonscript stopped working:

    Think about what you just said!

    Clearly, and sadly, there isn’t much thinking going on.
    The same dumb thing was said HERE, turning the dumbness into an official complaint against a great piece of software. :-(

Log in to reply