Notepad++ stopped saving closed tabs



  • Re: Notepad++ stopped saving closed tabs

    Hi, I’m replying in relation to another subject I opened in June. I’m sorry, but I had no access to the device, so I could not respond to you before.

    As mentioned there, I had problem with the session saving in Notepad++ - the files are saved the way they were saved in April. Since then the tab session is not being saved.
    As you can see there, the option for remebering current session is active. I also checked session.xml file - I do not have read-only permission, the file properties has this option unmarked.
    Not sure about more than one instances of Notepad++. In Task Manager there’s only one process of Notepad++ - not sure if that is the right indicator though.
    Last thing, I am attaching the requested debug info. Also please see another screenshot - it sees the last session dated in April, which can be seen by the last files history shown on screenshot.
    debug.PNG notepad.png

    Best regards,
    Igor



  • @Igor-Holewiński

    7.5.6 is way too old to make continued discussion about your issue viable.
    I’d advise you to update to 7.8.9 and see if the problem persists.
    If it does, come back here and post.



  • @Igor-Holewiński

    I should have added that if you return to post, just do it by continuing to contribute to this thread. (Not sure why you created a new one–this one–instead of just continuing the earlier one you linked to at the top?)



  • @Alan-Kilborn

    I tried to go with the previous topic, but it was locked already due to the period of time that passed.
    I wish I could install the update for that, but the issue occurs on organizational laptop. This version is the only available and is not installed as downloaded .exe file, but from organizational intranet portal with limited access to software. Anything else that could be done in this case?



  • @Igor-Holewiński said in Notepad++ stopped saving closed tabs:

    I tried to go with the previous topic, but it was locked already due to the period of time that passed.

    This one? https://community.notepad-plus-plus.org/topic/19593/notepad-stopped-saving-closed-tabs

    It is from June of 2020 which is hardly long ago.
    It isn’t locked for me, but I’ve seen strange things with threads becoming locked in the past.
    No matter, we’ve got this current thread going now…

    Anything else that could be done in this case?

    I’m clueless on how best to continue debugging, but maybe someone else has an idea.



  • @Igor-Holewiński ,

    I just downloaded a fresh zip copy of npp.7.5.6.bin.x64.zip from the official downloads site, and was able to save my session just fine.

    In comparing your Debug Info to mine, I noticed a couple of interesting things:
    Yours =
    Mine = 26f7f76a-a825-45d6-a88d-f571adf0b82c-image.png

    1. Your Debug Info clearly indicates it’s a 64-bit version, but it’s in Windows’ 32-bit-program hierarchy of C:\Program Files (x86).

      QUESTION: Can you move the application to the C:\Program Files\ hierarchy instead of the C:\Program Files (x86)\ hierarchy? Because right now, the location is telling Windows it’s a 32-bit application, but it’s actually a 64-bit executable. I have no idea how that might confuse Windows.

    2. Both of ours show as Local Conf mode (which means that it uses the application directory for storing settings) – and that surprised me, given your installation directory. In my case, that is C:\usr\local\apps\npp-other\npp.7.5.6.bin.x64\, which I know is a writable directory for me. However, in your case, that would be C:\Program Files (x86)\NPP\Notepad Plus Plus\, which is in the protected Program Files (x86) hierarchy.

      QUESTION: do you have write permission in C:\Program Files (x86)\NPP\Notepad Plus Plus\? If you do not, then Notepad++ cannot save its session files, or any other config files changes you make.

      If you do not have write permission, you will have to ask your I.T. to come give temporary permission, and delete the doLocalConf.xml file. After that, you no longer need write permission in that directory.
      When you re-start, this will tell Notepad++ to use %AppData%\Notepad++\ for storing Notepad++ settings, rather than trying to use the application directory. You will have write permission in %AppData%\Notepad++\ folder, so your settings (including the sessions.xml file) will be able to be saved again.

      Alternatively, you could move it completely out of the C:\Program Files hierarchies, and to some folder where you will always have write permission. (At work, I have set up a folder called c:\usr\local\apps which holds things like Notepad++, so that I don’t have to deal with I.T.'s rules on C:\Program Files)

    3. It’s unfortunate that your I.T. group has locked you into an outdated and unsupported version of Notepad++. Since you have no plugins (as evidenced by Debug Info), it would be really easy for them to allow you to use the newest v7.8.9 instead. (The biggest hurdle in upgrading from v7.5.x to anything v7.6.x or newer is the changes regarding handling of plugins; since you don’t have any plugins, that’s a non-issue, and the upgrade would be seamless.)

      SUGGESTION: while you are talking with I.T. about write-permission to delete doLocalConf.xml, ask them if they could change their supported version to NPP v7.8.9.

    PS: when I look at Notepad++ stopped saving closed tabs, it does not indicate that it’s locked. It politely asks if you want to create a new topic instead, but all you have to do is click on Reply to this topic anyway and it will allow you to compose a reply.
    a74b610a-664e-4d10-84f9-85db58a76586-image.png
    At this point, don’t reply there, because the conversation has already continued here, and it would just add more confusion to hop back.



  • @Igor-Holewiński ,

    BTW: my theory #2 (write permission in that folder) is exactly what @Ekopalypse said in Notepad++ stopped saving closed tabs:

    The session is saved in the session.xml file.
    is it possible that you still have read permission
    but no write permission to this file?



  • @PeterJones

    Actually C:\Program Files (x86)\NPP\Notepad Plus Plus\ folder was set to read-only mode. I have set it to modify type and deleted the file doLocalConf.xml. It required admin rights, which surpisingly I had at this point. I guess that my company’s policy regarding this is different in various cases, for example I cannot install any software of my own, but I am able to perform this action.
    Anyway, after running Notepad++ again it cleared my tab session, but after having a new one and shutting the application, it was still present there after restarting NPP. So, the issue was solved by the step 2 from your post.

    Thank you very much for your help, that was really annoying thing to deal with on everyday basis.


Log in to reply