Dancing text selection



  • I have a High DPI laptop with Window 10. I am using Notepad++ v7.8.9.

    When I select text, the selection moves to the right. The selection moves to the right adding spaces at the end of the selection box causing the rest of the text to be moved over. When I unselect the text, the extra spaces are removed.

    Is this a bug or “feature” (maybe to mess with intoxicated people)?

    Seriously, I am hoping there is a text file I can adjust or setting I can change. Otherwise, I have been using this text editor for a few years now, and I love it. Keep up the good work.



  • @Joseph-McCay ,

    There are some known issues with High DPI. I don’t know if this “dancing text selection” is one of them. (I don’t have high DPI, so cannot test)

    Also, you might want to see if one of your plugins is causing the issue: run with the -noPlugin command line argument and see if the problem persists: if it goes away, it was one of your plugins. You can then start trying plugins one at a time to see which causes it to come back (if you rename the folders in <installdir>/plugins/ and re-run Notepad++, any plugin whose folder name was changed will not be loaded; so you could rename them all, then one-at-a-time name them correctly again, until the problem comes back.)

    Or you may have to wait for a user with High DPI to chime in, if they have seen this.

    “feature” (maybe to mess with intoxicated people)?

    The developer has an odd sense of humor, but I doubt he adds “features” to intentionally mess with people (unless you consider the ghost-typing and easter-egg options to be “messing with people”). :-)


Log in to reply