SCI_LINEDOWNRECTEXTEND issue



  • Hi, everyone. I have a problem with the SCI_LINEDOWNRECTEXTEND shortcut Alt+Shift+Down. I just got a new PC, so I installed last version of Notepad++ and this is not working. I see there was a topic about this, but it seems it remained unsolved for three years, and I think it’s not the same problem I’m facing. The thing is:

    • All other similar functions work properly (up, left, right).
    • The other features mapped with the arrow down work properly too.
    • If I remap SCI_LINEDOWNRECTEXTEND to Ctrl+Alt+Down or Ctrl+Alt+Shift+Up, it works; if I remap it to Ctrl+Alt+Shift+Down, it doesn’t, so there seems to be some kind of conflict with the “Alt+Shift+Down” combination, but the program itself says there’s no conflict with any other shortcut.
    • If I just hold Alt and drag with my mouse, it works properly too.

    I’ve tried using the previous version of Notepad++ (7.8.9, currently using 7.9) and also the portable version, but the same issue occurs. Now, interestingly enough, if I use the arrow down in the number pad (number 2), the classic Alt+Shift+Down combination actually works (and also leaves a ☻ icon :P).

    So, while I could just remap or add a second shortcut for SCI_LINEDOWNRECTEXTEND (and its siblings), I’d like to get this to work, as I’m really used to it. Any ideas?

    Just in case it helps, I didn’t edited any other preferences that can cause conflict with this, and this is the info I get in the Debug Info option:

    Notepad++ v7.9 (64-bit)
    Build time : Sep 22 2020 - 03:19:04
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Pro (64-bit)
    OS Version : 2004
    OS Build : 19041.450
    Current ANSI codepage : 1252
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll



  • @Javi-Mik said in SCI_LINEDOWNRECTEXTEND issue:

    I have a problem with the SCI_LINEDOWNRECTEXTEND shortcut Alt+Shift+Down…this is not working

    Hmm, works for me in the same version, and I suspect it also works fine for the vast majority of users. But that just means we may have to work harder to get to the root of the issue for you.

    My best guess is that there is some other program running that is stealing this particular keycombination in the form of a “global hot key” and that Notepad++ itself is never seeing it. All your evidence points this way.



  • Mmm can’t think of anything. I only had open Google Chrome and Telegram Desktop, and I tried rebooting the system and checking if it still didn’t work with everything closed, but it didn’t =/

    Definitely is something related to this specific PC. This is my personal computer, but I use Notepad++ in my old laptop and my work PC too and I don’t have this problem in there, so I tried uninstalling v7.9 and installing v7.8.6, the one I use at work, and the issue remains.

    Just in case, I tried using “Alt+Down” and that works, so again, the problem seems to be particularly the combination “Alt+Shift+Down”.

    I’ll keep looking in case any of you guys come up with the solution, and I’ll try to get used to use just “Alt+Down” in the meanwhile, which apparently cause no conflict with any other shortcut.

    Thanks for your help!



  • @Javi-Mik said in SCI_LINEDOWNRECTEXTEND issue:

    Mmm can’t think of anything.

    Your memory is not a reliable way to check for a global hotkey registration. :-)

    I only had open Google Chrome and Telegram Desktop, and I tried rebooting the system and checking if it still didn’t work with everything closed

    I hate to be the bearer of bad news, but even when you think you aren’t running anything, there is a ton of stuff running that you are unaware of.

    the problem seems to be particularly the combination “Alt+Shift+Down”

    Again, consistent with something “stealing” this particular combination.

    I’ve never used it, but maybe give this a whirl:

    https://www.nirsoft.net/utils/hot_keys_list.html

    Of course, it could be something else, but I really think you need to eliminate this possibility first.

    Now, interestingly enough, if I use the arrow down in the number pad (number 2), the classic Alt+Shift+Down combination actually works (and also leaves a ☻ icon :P).

    So this is different from the standard Alt+Shift+Down.
    But it does show that the function is running in Notepad++, so this slightly-different keycombo is getting through to N++.

    The fact that it leaves you with ☻seems to be indicative of this open issue with Notepad++:
    https://github.com/notepad-plus-plus/notepad-plus-plus/issues/5321

    But that issue is unrelated to your real problem.



  • @Javi-Mik

    Another thing you could try is to run another program that uses the “Shift+Alt+arrows” keycombos to do something.

    Visual Studio’s code editor supports this, so you could try it there, but I suspect maybe you aren’t a user of this. Same for the text editing product with the confusing name called “VS Code”.

    An easy download of something you could try is the SciTE text editor: https://www.scintilla.org/SciTEDownload.html
    If you’re inclined, grab that executable, run it, put some lines of text in it and try to select a column block with your problematic “Shift+Alt+Down”. My bet is that it will not work there either.



  • I hate to be the bearer of bad news, but even when you think you aren’t running anything, there is a ton of stuff running that you are unaware of.

    Yeah, I guessed, that’s why I tried rebooting (I also checked processes in Task Manager but I had no idea what could possibly cause this issue… =/)

    I’ve never used it, but maybe give this a whirl:

    https://www.nirsoft.net/utils/hot_keys_list.html

    Of course, it could be something else, but I really think you need to eliminate this possibility first.

    Just checked and “Alt+Shift+Down” doesn’t appear in the list, but…

    If you’re inclined, grab that executable, run it, put some lines of text in it and try to select a column block with your problematic “Shift+Alt+Down”. My bet is that it will not work there either.

    Yeah, exactly. I tried that and it’s not working either =/



  • @Javi-Mik said in SCI_LINEDOWNRECTEXTEND issue:

    I tried that and it’s not working either

    …which points to something other than Notepad++ causing this problem. Unfortunately, I’m out of ideas on what it could be. :-(



  • @Javi-Mik
    Could it be that your keyboard layout isn’t what you think it should be?



  • @Ekopalypse said in SCI_LINEDOWNRECTEXTEND issue:

    Could it be that your keyboard layout isn’t what you think it should be?

    I’m intrigued by this. :-)
    How does one misinterpret which key is “down”?



  • @Alan-Kilborn

    If your physical keyboard has, let’s say, English layout then the z key
    is in the second row (counted from bottom to top) on the left side.
    Now if you add another keyboard layout like German, the z becomes a y.
    Maybe there is also a keyboard layout which allows remapping of arrow and ctrl/shift keys !??



  • @Ekopalypse said in SCI_LINEDOWNRECTEXTEND issue:

    Maybe there is also a keyboard layout which allows remapping of arrow and ctrl/shift keys !??

    Or maybe the “down” key?
    Because OP didn’t have problem with other Shift+Alt+arrow combinations.



  • It is possible in Windows 10 to change to a different keyboard layout, such as Dvorak. Of course the key indicators might say one thing but the layout loaded dictates what character is shown on screen when a key is pressed.

    One would have to be a touch typist in this instance, but I don’t think we are in this situation for this issue.

    Another thought is the display driver. It’s possible to invert or rotate the screen output using hot keys, although if they were active I would suspect we’d be seeing a screen rotation as the hotkey was pressed. That option can be turned off in the display settings but then I would assume the hotkey would then be apparent to Notepad++ and there would be no issue. But it might be worth a look to see if the problematic hotkey is used by the display driver.

    Terry



  • As more as I think about it I don’t think it is related to different keyboard layout but to have different keyboard layouts configured. The default key combination to switch between layouts is LEFT ALT + SHIFT. And it is not listed in HotKeyList.



  • @Ekopalypse

    But testing this reveals that the layout gets switched but column selection still works :-(


Log in to reply