Selicting "file" with firefox open gives me the firefox directory



  • If I click on the file ‘icon’ in ++ I get the firefox menu and I’m actually in firefox than. I can click on a file from the file directory in ++ and it gets me there but asking for a directory of files gets me in FireFox. Somebody recently updated and this started, not sure just who’s problem it is. I hope that is clear enough.



  • @Esmee-Lohgynn said in Selicting "file" with firefox open gives me the firefox directory:

    I hope that is clear enough.

    Nope, at least not for me.
    If others don’t chime in with saying it is clear to them, and offering solutions, perhaps you should consider rephrasing.



  • OK Re-phrasing. The top of ++ there is a word “File”. Clicking on it brings up many things, mine shows a “new” and an “Open…” a bunch of things and the last 10 files I opened. I can click on any of the last 10 files I opened and everything works fine. If I click on “open” (or the little icon for a file folder) it opens the directory in firefox, I believe I am now in firefox. A clicked on file from here will “open” in ff. I can have ff minimized, and recently I can even have it closed and I click on “open” (in ++) and the ff open menu comes up, now I’m in ff.
    This just started like yesterday. Guessing ff or ++ just installed a new version, I didn’t do anything.
    I’ve used ++ for maybe 10 years and ff since the beginning of the WEB, almost.



  • OK, sorry, it doesn’t appear to be a ++ problem. More like a microsoft problem. My search on the computer with ++ closed is all screwed up. Is it possible to go back to the previous update?
    Thanks for looking…



  • Are you telling me, by the lack of answers/feedback, that nobody else is having this problem??



  • @Esmee-Lohgynn said in Selicting "file" with firefox open gives me the firefox directory:

    by the lack of answers/feedback, that nobody else is having this problem??

    Possibly or maybe as @Alan-Kilborn said, your problem does not appear apparent. Obviously rephrasing a second time did not get anyone’s attention either.

    Have you considered posting a couple of screen images perhaps. Some on this forum have also used a screen recorder so it shows like a mini video. That might allow us to better understand the problem

    Terry



  • @Terry-R said in Selicting "file" with firefox open gives me the firefox directory:

    screen recorder so it shows like a mini video.

    One such program used is
    https://www.screentogif.com/

    Terry



  • Thanks for answering, I am still having the problem and I tried to report it to microsoft but they have made it impossible without selling my soul. I reported a possible problem to firefox.xx1.png
    OK I took a screen shot of the “file” screen in ++. everything there is OK. I can go down and click any of the 10 previously edited files and it goes there instantly. If I click on “open” I go to like the browser directory, it is definitely not the ++ directory and any file I click opens in the browser. It is a crippling problem for me but I can’t find any one else with the problem. I do only a very limited # of things on the computer and I have been doing the same thing for 15 years so why is it? If you got any ideas I would be glad to hear them… thanks.



  • @Esmee-Lohgynn said in Selicting "file" with firefox open gives me the firefox directory:

    If I click on “open” I go to like the browser directory, it is definitely not the ++ directory and any file I click opens in the browser

    Unfortunately that screen image doesn’t help. Can you possibly try the program I mentioned. It will take a number of screen shots in succession and then combine it as a GIF image. Post that so can see exactly what you mean. Set it up so you are only running it for the short time you click on Open and then on a file which opens in another program which you suspect is Firefox

    Terry



  • It sounds to me like some sort of malware has gotten hold of the File > Open somehow.
    Does this happen in ALL programs on your computer, or just Notepad++?
    How about regular Windows’ notepad.exe?

    I could see malware/adware using this opportunity to take you to a website of its own devising.

    But, it is a strange one.



  • Hi, well thanks for hanging in there. OK to answer Alan, I’m not positive. Microsoft products all seem to open in the same directory, at least what I have but I checked 4 other programs and they open in their own directory, today, now, except ++. I included a second screen shot and that is all there is, the first one of the ++ directory and when I click on open I get the microsoft (I guess) directory, certainly not the ++ directory, or did something change? Anyway clicking in the second directory, brings up the file in the browser, not ++, as I have said before, but sorry I can’t explain what I see any better.

    So I click on “file” (IN ++) and I get the first screen shot I sent. If I click on “open” I get the second screen shot, the microsoft/ browser directory. And I did indicate once it happens when firefox was open but that doesn’t matter, it happens with only “edge” open too.
    I’ll try an “un-install” of ++ now that it is suspect and reload. I have no idea…xx1.png



  • Well, that seems to have fixed it. Weird. When I click on a file now it opens in ++ like it is supposed too. I guess I was confused about the directory which didn’t help, I was thinking it opened in a special directory, not sure what the thinking was. Anyway I would have tried that earlier had I thought the problem was on ++, on my computer. Thanks to all that attempted to help and in fact you did. I did install the earlier version and it appears I cannot turn off auto update.



  • @Esmee-Lohgynn said in Selicting "file" with firefox open gives me the firefox directory:

    and it appears I cannot turn off auto update

    You can, its:
    2d113afa-9e06-4206-8be9-ceeb79ed3721-image.png

    Terry



  • Well, it is definitely a different directory. The previous directory would list the files in multiple columns and this one doesn’t. When I type in the file name it doesn’t finish filling it in either. I still think I’m now getting a DOS directory instead of the notepad and it has brought up the file in the browser a couple of times but I can’t repeat the problem. thanks Terry, I guess the problem wasn’t due to a notepad update but I will keep that in mind.


Log in to reply