Np++ no styles when start



  • Hello all … i have problem, when I open notepad++ no styles are showing, only when I reopen file.

    Notepad++ v7.9.1 (64-bit)
    Build time : Nov 2 2020 - 01:07:46
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS Name : Windows 7 Home Premium (64-bit)
    OS Build : 7601.0
    Current ANSI codepage : 1250
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll

    thank u for any help …



  • @Celestin-Noha

    Is that for ANY file type?
    Or just one?
    Like, as an example, it happens for you that way when you open a C++ (.cpp) file, but not Python (.py) files?

    Really, I think you’ll have to provide a bit more to go on, since I don’t think others are experiencing this with 7.9.1 (or we’d get more postings on it)



  • @Alan-Kilborn probably its in any filetype … im using php,css,html,javascript … thanx



  • @Celestin-Noha,

    probably its in any filetype … im using php,css,html,javascript

    And every filetype that I have opened in my last month of using v7.9.1 64-bit as my primary editor have properly syntax highlighted, whether perl, XML, c, c++, or my various UDLs, and anything else I’ve tried while helping people in the forum.

    It’s working for me. If it’s not working for you, you’ll have to give us a little more to go on than “it’s not working”. Screenshots would be nice – show the file open, with the right extension, proving that the correct lexer is chosen. If you do give a screenshot, make sure your Notepad++ window is wide enough that the status bar gives the name of the active syntax language in the lower-left (like Normal text file or R programming language or eXtensible Markup Language file)
    For example, here is it working from a recent R language example in another post:
    .

    Notice that my screenshot shows the R programming language in the lower left, proving that Notepad++ recognizes it as an R source file.

    Based on your lack of information, my guess is that you started typing a blank file, so there is no syntax language selected (the lower-left status bar will say Normal text file if your Notepad++ window is wide enough), then you exit-and-save Notepad++ (giving the file a reasonable extension for the language), then when you re-open Notepad++, because Notepad++ sees an extension this time, it properly syntax highlights. But that’s just a guess, because even after Alan asked for more information, you gave virtually nothing.

    Please notice that, other than the Debug Info (thanks for that – most people forget to include that when asking for help, so it’s nice when someone does), you have only given two sentences in describing your problem. Alan and I, on the other hand, have given five to ten times that much in trying to extract meaningful information from you – we obviously want to help you, otherwise we wouldn’t be putting in that much effort. But you will get better help if you give better information.

    Good luck.



  • Here is my scr :screen.jpg

    btw im using slightly edited bespin theme … thanx



  • i see it now … its open as normal text file but only if recent files are open



  • @Celestin-Noha said in Np++ no styles when start:

    i see it now … its open as normal text file but only if recent files are open

    I have never seen Notepad++ open the file as the wrong type, even if “recent files are open”.

    Well, let me append: unless I had manually tweaked the Language setting for an open file, then closed Notepad++ and re-opened (so that Notepad++ remembers that you forced the language to Normal text file)

    I recommend that on any files that are wrongly Normal text file that you go to the Language menu and pick the right language for that file. Notepad++ will remember that setting from run to run, as long as it’s using the same session (Settings > Preferences > Backup > ☑ Remember current session for next launch).

    If I force a CSS file to Normal text file, then exit Notepad++ and re-run, it remembers the wrong highlighter. But if it’s forced to Normal then I close the file (without exiting Notepad++ too), I can re-open the file in Notepad++ and it will go back to being highlighted as CSS.

    If it continues to show files under the wrong type, maybe you’ve got conflicting extensions in the Style Configurator’s User ext.: box for some languages, or some other strange configuration bug. Or maybe a plugin is interfering with file detection. Sharing your ?-menu Debug Info might give some insight to us. Also, if you have a reliable sequence that always gets the file to open wrongly as Normal text file, if you could give us the exact sequence (making sure to include things like whether you open the file by using the Folder as Workspace you show on the left, or whether you use File > Open, or whether you use the Windows Explorer to drag the file into Notepad++, or double-click in Windows Explorer, or RightClick > Open in Notepad++ or some other sequence to open the file).



  • @PeterJones said in Np++ no styles when start:

    Sharing your ?-menu Debug Info

    Just to say, that info is in the OP’s first post of this thread.



  • @Alan-Kilborn said in Np++ no styles when start:

    Just to say, that info is in the OP’s first post of this thread.

    Okay, apparently I didn’t get enough sleep last night. ;-)

    Getting an exact sequence of events to replicate the problem would still be useful.



  • @Celestin-Noha
    How you open files? Auto load from session when NPP is running? Sometimes NPP breaks the last session file and it has wrong formatting for opened files (always used Normal Text). Try change it manually to correct and close/open NPP again (session should be saved again). I don’t know exactly when this happens, but I’ve had it a couple of times.



  • Thanx you all … its working now :) … i didnt do anything … and suddenly its ok … maybe its relate with corrupted ram which i change today … many thanx again


Log in to reply