dictionary and spell check



  • have used notepad++ for years to code my websites. I got a new laptop and cannot get spell check to work. I have downloaded the Aspell dictionary, but it still doesn’t work. It says I do not have a word list. What am I doing wrong? It installed with no problem on my last laptop. Windows 10 if that makes any difference. Thanks!



  • @Kris-Halbur ,

    What am I doing wrong?

    You didn’t give a load of information as to what you did, so it’s hard to say what you are doing wrong. But we can guess what you might be doing wrong.

    I had never tried the Aspell library for the DSpellCheck plugin. I decided to give it a try in a fresh portable Notepad++ to see if I could help you. Based on the Aspell page that the DSpellCheck links to, it looks like you need to install the dictionary choice(s) separately from the Aspell library. I don’t know whether that’s what you did.

    For me, I was worried by the “This port is no longer supported.” bold print. Then after downloading and installing the library and the English dictionary, when I tried to point DSpellCheck to it, I was told that it was a 32bit DLL and I have 64-bit Notepad++.

    After unzipping a 32-bit portable Notepad++ instead, then installing the DSpellCheck there, then attaching it to the Aspell library and choosing which variant of the English dictionary I wanted, it worked just fine for me, and found the dictionary and would show misspelled words. Since it worked for me, I am stronger in my guess that you just didn’t install the Aspell dictionary on your new laptop.

    (Personally, I find the Hunspell is easier to set up, because you don’t need the separate library to link to. I’ve installed it multiple times when helping people here, and didn’t have to go over as many hurdles as I just did to try Aspell.)



  • I too have lused ++ for years. a spell checker would be a great time saver for me. I’m not a computer nerd but I’m not ignorant about using them either. I tried installing the spell check and I guess I needed the nerd. In ++ under Plugins it says: spell-checker and you click on that and I get a windown that says: “GN Spell and/or directories are missing, download installation files here: http://aspell.net/win32/” which I have done several times. I don’t know where the files went, normally it is to where they should go and if there is a problem it tells you. fine. It still doesn’t work. There is also another line in that same window: “If Aspell is already installed, do correction of relative path aspell-15.dll and restart.” than there is a slot indicating part of a path:" •••\Aspell\bin". So? Still nothing. I went in and downloaded a aspell dictionary, it is in a zip file in my downloads folder… I eventually put it in the Aspell folder under program files. I still don’t know what/where the “bin” file goes. It is also 32 bit and ++ is 64 I think, I’m not sure anymore.

    I would like to click on something and it would load a spell checker in notepad and I could use it & not finding a computer geek that could put all this crap where it is supposed to be.

    So, can we fix this? Is it fixable? something about it being 32 bit and won’t work with the 64 bit ++ is a bit worrysome. I don’t even know who you would ever get back to me with an answer should that actually happen. I’ll try to watch this. Have a good year…



  • @Esmee-Lohgynn ,

    I don’t see “spell-checker” in the Plugins Admin list. I see “DSpellCheck”. Being accurate in your description of what you are doing is essential to getting good quality help.

    I don’t understand why people seem to switch from the Hunspell to the Aspell library in the DSpellCheck settings without good reason, and without saying they did so. When I install DSpellCheck, it always defaults to Hunspell. Then all you have to do is click on Download, and pick the language(s) you want, Install Selected, and Apply. From then on, it just works.

    c24083be-2f30-47ef-b5c5-886773942fe5-image.png

    Try to get Hunspell working, with the simple steps I outlined above.

    Don’t choose Aspell library unless you are absolutely sure that’s what you want, and know what you’re doing.



  • Hi, follow-up. I go spell working, I think. FYI if I click on the “?” in ++ it brings up a window asking about the path for Aspell and guessing that is where i got off course. thanks, this marginally computer literate appreciates your help.


Log in to reply