Missing .CSV Save As Extension



  • For the past two updates, the save as .CSV option has been missing. I download and edit a lot of these files for my employer, but I need to save them in a different folder than “Downloads”. The .CSV extension is missing, so I need to scroll up to the “*” All files, which usually requires some slow, scroll bar action.

    Is there a workaround, some option I’m missing to add that extension back to the list?



  • @Mark-Colbath

    I checked back many versions, and I don’t see a “csv” SaveAs choice at all. But perhaps I just don’t see it in the long list?
    It certainly doesn’t appear in the section with the rest that start with “c”:

    a1865b66-9313-48c6-a35b-179baf99da97-image.png

    Notepad++ doesn’t even recognize “csv” as a “Language”; nothing in this list:

    9b376c7f-4d4b-4594-b8dc-e579f2aa84b4-image.png

    But I think the true solution for you is to just type ., c, s, and v after your desired base filename, when saving.

    And, if you want to see the existing csv files in the current folder, so that you don’t give a new file the same name as an existing file, just type *.csv and hit Enter and the display will change to show you only those files. You can then proceed to give your file a name (but still, adding the .csv on the end of it).

    And, if you happen to be one of those that think that SaveAs changes your file content somehow, if you specify a certain type, then, well, Notepad++ is simply a text editor, and saves everything the same way: as text. (Contrast this with MS Office, for example, that definitely saves files in with vastly different content if one chooses .xlsx versus .csv, for ex.).



  • @Mark-Colbath said in Missing .CSV Save As Extension:

    I need to scroll up to the “*” All files, which usually requires some slow, scroll bar action.
    Is there a workaround

    Instead of scrolling, once you’ve clicked on the Save As Type dropdown, you can hit the HOME key to take you to the top. That might be faster than scrolling, if you have a hand on the keyboard already.

    But typing the extension – which you have to do after you pick All types (*.*) anyway – is faster than scrolling or hitting HOME.



  • @PeterJones said in Missing .CSV Save As Extension:

    But typing the extension – which you have to do after you pick All types (.) anyway – is faster than scrolling or hitting HOME.

    Caveat for @Mark-Colbath to understand:

    For the specific example of .csv as the extension, that process works. However, if you are trying to type an extension that your Windows system doesn’t know (not Notepad++; Windows itself… using regedit.exe > Computer > HKEY_CLASSES_ROOT will list all the extensions that Windows “knows”), then the Microsoft-written dialog that Notepad++ uses will automatically apply the default extension of the selected Save As type.

    For example, if I take a file that was originally blah.xml, and do a Save As, the Type starts as XML (understandably). If you manually type blah.csv as the file name, Windows will happily let that extension stand, so will create blah.csv. However, if you take that same blah.xml and do a Save As and manually type blah.blech (where Windows doesn’t know the .blech extension, as seen in the registry), then Windows will assume you are being lazy, and will automatically apply the first extension for the Save As type – in this case, .xml – calling the file blah.blech.xml). But with SaveAs type of *.*, typing blah.blech will give you what you want… so there can be a benefit to that SaveAs type.

    So for your .csv case, you should be able to just type it, without having to worry about the Save As type. If you have a weird extension like .blech, you might want to teach Windows about that extension (associating that extension with an app like Notepad++ should be sufficient, or manually regedit to add that extension to the registry might work as well).

    With all that said, there is another option (literally): if you are opening lots of files that have no extension to start with, you might consider changing the Settings > Preferences > MISC. > Set Save dialog file extension filter to .* instead of .txt for Normal Text option, which will make the default Save As type as *.* instead of *.txt, so then you can default to typing the extension for plain text files.



  • @PeterJones said in Missing .CSV Save As Extension:

    With all that said, there is another option (literally): if you are opening lots of files that have no extension to start with, you might consider changing the Settings > Preferences > MISC. > Set Save dialog file extension filter to .* instead of .txt for Normal Text option, which will make the default Save As type as . instead of *.txt, so then you can default to typing the extension for plain text files.

    As someone (“bReathl3sS”) points out HERE it appears that setting is going to get a tweak soon. Not sure if that impacts anything said right here, but I wanted to point it out for future readers, in case it does.


Log in to reply