I cannot save Language: Global Styles Default Style font name



  • I don’t know why I cannot save Language: Global Styles > font name.
    When I change the font name and click “Save & Close”. And close the notepad++ . Open again, the font name will auto rollback to default “Courier New”.

    Settings > Style Configurator > Language: Global Styles > Style: Default Style > Font name.

    Windows 10 (64 bit) , notepad ++ v7.9.1 (32 bit)



  • @R-Y ,

    I cannot replicate.

    When I set the font, exit, and reload, it saves the font.

    08a1bd06-0e10-49fe-b23f-024a23826712-image.png

    Don’t forget to go back to Default style, not the Global override when you re-open Notepad++ to verify whether it stuck.

    My best guess is that you are having write permission issues on stylers.xml. To point you to the right location for that file, you’d have to give us the Debug Info (? menu’s Debug Info entry – shown in my screenshot, but you can just copy the text and paste it here if you want). But it’s probably %AppData%\Notepad++\stylers.xml : if you verify your Debug Info says “Local conf mode: OFF”, and if you don’t have Cloud settings turned on, then that will be the location. If that’s the case, open Windows Explorer, and paste in %AppData%\Notepad++\ and make sure that you have write permission to all the files in there.


Log in to reply