DSpellCheck not working



  • It doesn’t show red underscore.
    ab1064e8-cd3b-4f0a-b6ce-801af0982ad8-image.png

    I just installed a fresh Notepad++.
    debug info:
    Notepad++ v7.9.2 (32-bit)
    Build time : Dec 31 2020 - 03:58:36
    Path : C:\Users\carlo\Downloads\npp.7.9.2.portable\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 2009
    OS Build : 19042.685
    Current ANSI codepage : 950
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll

    settings:
    3a93bc15-78cc-45d6-bd75-0392bc7dc2b3-image.png
    Thanks!



  • @Carlos-Zhang-0 ,

    I just did a fresh unip of 7.9.2-32bit, instaled DSpellCheck with Hunspell, installed and selected the English (United States) dictionary, hit Apply, and it started spell checking the current document with no issue.
    70cd4b46-3b8d-4022-b3a5-5aac34209d46-image.png

    Did you remember to apply your settings after you downloaded the dictionary?

    if so, you might look in the Hunspell Dictionaries Path, and make sure it properly downloaded the file en_US.dic at about 550kBytes



  • Hi @PeterJones,
    Thanks for replying.

    Did you remember to apply your settings after you downloaded the dictionary?

    This “apply”? Yes I did.
    6db2a9b2-fc04-4adb-8d1e-8a82b9ca9fc4-image.png

    if so, you might look in the Hunspell Dictionaries Path, and make sure it properly downloaded the file en_US.dic at about 550kBytes

    Looks good.
    9ca92aa7-5d14-4664-ab00-3ad9388c51de-image.png



  • I just found it works only if it’s a comment line.
    921ed5d2-e659-4337-ab90-fa2a6a07b9e5-image.png



  • @Carlos-Zhang-0

    …and you must have set a “Language” on your “new 1” tab without reporting that. The fact that you just had gibberish data in the tab also didn’t help (I get that you were just trying to test the speller). But, if it had been real language data (be it php, python, whatever), it would have been easier for someone here to help solve.



  • @Alan-Kilborn
    Didn’t set any language.
    071a20af-0433-4e57-97ef-fb4bc6d71a8a-image.png



  • @Carlos-Zhang-0

    Well then I suppose it is very interesting that the spellchecker thinks that “Normal text” files have any notion of comment lines! :-)

    I wonder (but don’t care enough to check as I don’t have a spellchecker plugin installed) if it thinks lines that start with // are comment lines as well as those that start with #





  • @Carlos-Zhang-0
    I just found it works fine only if I change language to user-defined.
    9a07a608-e2e1-41f7-9e7a-f378e69e9fa1-image.png
    Not sure why it doesn’t work for normal text.



  • @Carlos-Zhang-0

    Have you noticed these settings which you showed?
    Especially where it says “in code”:

    Imgur

    But still, curious why it thinks “normal text” is “code”.

    In 7.9.2, a change was made in the Language so that files with no set type are now called “None (Normal Text)”. Before 7.9.2, they were called “Normal Text” (and were buried under the “N” submenu).

    Perhaps the spellchecker plugin is keying off of this?
    Meaning that it is looking for exactly “Normal Text” and, since it doesn’t see this, it thinks the tab is made up of “code”?

    @guy038 and I had some discussion about how this change should not affect anything (that was MY opinion) and Guy maybe thought the opposite – and now perhaps Guy was right? :-)



  • @Alan-Kilborn
    But it works fine on your computer. Weird.



  • Hello, @carlos-zhang-0, @alan-kilborn, @peterjones,

    As for me, it works nice, with N++ v7.9.2

    • Whatever the language used is Normal Text or User-Defined

    • Whatever the file encoding ( ANSI, UTF-8[-BOM], UCS-2 [BE|LE] BOM )

    • Whatever text is considered as comments or not, when language is Normal Text or User-Defined

    • When text is in comments or strings when language is a specific language, as C++ or Python

    Note that I’m using the DSpellCheck v1.4.15.0 version which is the last version working with my OS ( Windows XP SP3 ). So, the behaviour that you described could depend on the newer versions of the DSpellCheck plugin !

    938b420d-14a2-4d49-9e28-249213c89683-image.png

    f0b98823-1ccb-4971-b930-01743b27d60b-image.png

    Best Regards,

    guy038



  • @guy038
    Thanks. Maybe it’s a bug in the newer version.



  • @Carlos-Zhang-0 ,

    Once again, it works for me, as I showed above.
    In case you were curious, it’s with DSpellCheck v1.4.20.0, which is the newest available from Plugins Admin interface. So here’s a new screenshot showing some of your exact test cases working, along with other test cases from me.

    01393ea2-f7ab-4070-aa4d-b5df83f21ba1-image.png

    And a second screenshot with my (default) advanced settings, plus the Language menu pulled down to doubly confirm (along with the status bar showing “Normal Text File” as it did in my earlier screenshot). As you can see, DSpellCheck works just fine with Normal Text files, and doesn’t just check spelling on “comment” lines.

    fcb8644c-842d-4379-a0e6-a82c4b895c2d-image.png

    Everything works for me, as expected, with the most recent Notepad++ and most recent DSpellCheck from Plugins Admin.



  • @PeterJones
    Thanks. I do believe it works for you.
    I think maybe it’s environment issue. E.g. some settings in win10?


Log in to reply