'In Selection' grayed out in the find/replace box



  • I’m using v7.9.2 at present but this issue has been bugging me since at least v7.9 and possibly earlier.

    Sometime, seemingly at random, the ‘In Selection’ field will be grayed out in the search/replace box. My normal editing practice is to select a range of text and then to do Ctrl-H to bring up the find/replace box. At times, and I have not been able to understand the pattern, the ‘In selection’ field will be unselected and grayed out. I can’t toggle it on.

    When it’s in this state there are a couple of workarounds.

    1. I can switch to the Find tab and then back to the Replace tab. At that point ‘In selection’ is no longer grayed out and I can do Alt-I to toggle it on. However, to do this I need to use the mouse as I have not discovered any quick keyboard methods to switch between tabs.
    2. I can press Esc and then Ctrl-H again. Often times ‘In selected’ is then not grayed out. However, I then loose whatever I had entered in the ‘Find what’ field and need to re-enter this. While I could load that text into the copy/paste buffer I almost always have something else I want to retain in the copy/paste buffer.

    It’s been frustrating as the issue hits at random. While writing this post I tried several times to reproduce the issue. While it happened once doing the exact same selection again before the Ctrl-H resulted in ‘In selection’ not being grayed out.

    Usually it’s on small small multi-line selections.

    Notepad++ v7.9.2 (32-bit)
    Build time : Dec 31 2020 - 03:58:36
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Home (64-bit)
    OS Version : 1909
    OS Build : 18363.1256
    Current ANSI codepage : 1252
    Plugins : DSpellCheck.dll HexEditor.dll mimeTools.dll NppConverter.dll NppExport.dll NppTextFX.dll PythonScript.dll



  • @mkupper said in 'In Selection' grayed out in the find/replace box:

    Sometime, seemingly at random, the ‘In Selection’ field will be grayed out in the search/replace box.

    I have also been experiencing this issue. At random times (mostly when busy on a project or solution for somebody) it occurs. And as you say, changing from the Find to Replace tab (I most recently experienced it in Find) and then back seems to “release” it for use.

    As I’ve been busy at the time it occurs I’ve not spent much time on trying to replicate, and as you say it is difficult to get it to re-occur.

    Maybe we can get a “mob” of us to try and “break” it on demand. Then we’ll know how to replicate which is what the developers will need in order to find the issue in code.

    Cheers
    Terry



  • @mkupper ,

    I could be wrong, but this sounds like this recent discussion and also this earlier discussion. On those, I don’t know if anyone has bothered putting in an official github issue or not. But if what you describe is the same as those (especially the first I mentioned), and if there isn’t an existing issue in the repo, then maybe you would be willing to submit the report.


Log in to reply