Win 7: Connect file-extensions with NP 7.9.2



  • Hi
    I just installed current version 7.9.2 (German) on my Win 7, and basically it works. I can start and use it, I have “Open with Notepad ++” in my context menu.

    But I failed to “connect” the file extensions “.vva" and ".re” to Notepad, to be opened with double click.

    • I started NP as Admin
    • I started Settings - File and activated .log and .txt from “Notepad” and .ini from MS and added .re and .vva with “customize”
    • I checked the Registry - all extensions are defined as class “Notepad++ _file”, the class has the settings for “command - Open - notepad…”

    But…

    • only INI and TXT and LOG got the right icon and the right description in Explorer filelist
    • RE and VVA stayed unchanged
    • also using the contextmenu on RE - Open with … - select application - select from hard drive" fails: I can select NP++, but nothing happens - no sucess, no error

    How to connect the described extensions?



  • @Pierre-de-la-Verre ,

    Sorry. It sounds like you’ve followed the right steps. Did you remember to reboot or at least log out and log back in after making the registry changes?

    Sometimes Windows fights against changes to file associations – though normally the association problems I’ve heard of have been with Win10, not Win7.

    I am not sure how to fix your exact problem (I don’t have easy access to Win7). You might get more help if you share the exact registry contents for your .vva and .re entries, as well as the Notepad++_file entry. (And maybe show us the .txt or .log entries as well, so we can compare “working” to “not working”)

    Personally, other than the .txt, I don’t do any special “associations” with Notepad++. Instead, I add HKEY_CLASSES_ROOT\*\shell\Notepad++ entry, with command set to "C:\usr\local\apps\notepad++\notepad++.exe" "%1" (yes, those quote marks are literal characters in the definition) – this way, if I RightClick on any file type, I get an Edit with Notepad++ entry, so I can easily open any file type with Notepad++.

    If I export that HKEY_CLASSES_ROOT\*\shell\Notepad++ entry, it shows:

    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\*\shell\Notepad++]
    @="Edit With Notepad++"
    "Icon"=hex(2):43,00,3a,00,5c,00,75,00,73,00,72,00,5c,00,6c,00,6f,00,63,00,61,\
      00,6c,00,5c,00,61,00,70,00,70,00,73,00,5c,00,6e,00,6f,00,74,00,65,00,70,00,\
      61,00,64,00,2b,00,2b,00,5c,00,6e,00,6f,00,74,00,65,00,70,00,61,00,64,00,2b,\
      00,2b,00,2e,00,65,00,78,00,65,00,00,00
    
    [HKEY_CLASSES_ROOT\*\shell\Notepad++\command]
    @="\"C:\\usr\\local\\apps\\notepad++\\notepad++.exe\" \"%1\""
    


  • @PeterJones said in Win 7: Connect file-extensions with NP 7.9.2:

    Personally, other than the .txt, I don’t do any special “associations” with Notepad++. Instead, I add HKEY_CLASSES_ROOT*\shell\Notepad++ entry, with command set to “C:\usr\local\apps\notepad++\notepad++.exe” “%1” (yes, those quote marks are literal characters in the definition) – this way, if I RightClick on any file type, I get an Edit with Notepad++ entry, so I can easily open any file type with Notepad++.

    +1
    (Yea, don’t even bother with file associations inside N++)



  • As said in first post:

    @Pierre-de-la-Verre said in Win 7: Connect file-extensions with NP 7.9.2:

    I can start and use it, I have “Open with Notepad ++” in my context menu.

    So I’m just searching for the last 5% of perfect start behaviour …

    I will post the registry-values when I can reach the PC again.



  • So, here are the registry lines

    Windows Registry Editor Version 5.00
    
    [HKLM\SOFTWARE\Classes\Notepad++_file]
    @="Notepad++ Document"
    
    [HKLM\SOFTWARE\Classes\Notepad++_file\DefaultIcon]
    @="\"C:\\Program Files\\Notepad++\\notepad++.exe\",0"
    
    [HKLM\SOFTWARE\Classes\Notepad++_file\shell]
    
    [HKLM\SOFTWARE\Classes\Notepad++_file\shell\open]
    
    [HKLM\SOFTWARE\Classes\Notepad++_file\shell\open\command]
    @="\"C:\\Program Files\\Notepad++\\notepad++.exe\" \"%1\""
    
    Windows Registry Editor Version 5.00
    
    [HKLM\SOFTWARE\Classes\.log]
    @="Notepad++_file"
    "Notepad++_backup"="txtfile"
    
    Windows Registry Editor Version 5.00
    
    [HKLM\SOFTWARE\Classes\.re]
    @="Notepad++_file"
    
    Windows Registry Editor Version 5.00
    
    [HKLM\SOFTWARE\Classes\.vva]
    @="Notepad++_file"
    


  • @Pierre-de-la-Verre ,

    Under normal circumstances, that should be right.

    You mentioned having tried Explorer’s RightClick contextmenu “Open With” command. I believe that Windows stores those selections in the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts hierarchy. You might want to check the .log, .re, and .vva entries there. Also, if you have a HKEY_CURRENT_USER\Software\Classes\Applications\notepad++.exe or HKEY_CLASSES_ROOT\Applications\notepad++.exe, make sure those point to where you think they should. And HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\ApplicationAssociationToasts has value names like Applications\some.exe_.ext – I think that final .ext is showing a mapping from that extension to the application listed to the left; so if there are .log or .re or .vva endings in that list that aren’t mapped to notepad++.exe, you might want to delete them.

    After any registry changes, you might have to reboot to get those changes to apply.


    caveat emptor : change the registry at your own risk; if you are not careful, registry edits can make your computer or your particular login unusable



  • 99% solved, final resume:

    As usual, there where different issues, complementing each other - from the software and from me …

    • the current user has no admin-rights, so there is the usual problem of admin versus user
    • there was the 32bit of NP++ installed; the update to 64bit did not reset all registry-settings of 32bit
    • I checked the HKLM-settings and thought that this will overwrite the user-settings: my fault, existing user settings stayed alive
    • there where user settings for “.re” which linked to “re_auto_file” which linked to inactive x86-start-commands

    Now I cleaned up all x86-values to current links, and this enabled the command “Open with … - select Standard application …” again. Now a double-click on .VVA and .RE opens it with NP++

    The last “1% cosmetic unsolved” for both file types is that the icon in Explorer is smaller than the standard icon and the file-description is not “Notepad++ Document”.

    Thanks to all posters for advice!


Log in to reply