Can find this in page search, but not file search.



  • I am trying to run a find and replace on this:

          stack:
            ==: org.bukkit.inventory.ItemStack
            type: POTION
            damage: 16307
    

    I can find it just fine in the normal in-page search function, but cannot seem to find it in “Find in files” search, no matter what I try.

    I have tried using this with Extended:

          stack:\r\n            ==: org.bukkit.inventory.ItemStack\r\n            type: POTION\r\n            damage: 16307
    

    which finds it on the page, but finds nothing in file search.

    I have tried this with reg ex and matches newline selected:

    ([ ]+)stack:\r\n([ ]+)==: org.bukkit.inventory.ItemStack\r\n([ ]+)type: POTION\r\n([ ]+)damage: 16307
    

    which also finds it in-page, but not in file search.

    I don’t know what else to do… :(



  • nm, figured it out I think.

    I was using a new txt doc to copy the content to be searched for, but the content is in yml files, and seems to be formatted differently…or something. After searching for content copied from yml file, it was able to find it…


Log in to reply