Invoke find/replace with selection - selection box not marked



  • Hello,

    Version 7.9.2 64-bit.

    I have another text editor that, if find/replace is invoked with text already selected, the ‘find/replace in selection’ box is automatically marked for me.

    I could swear NPP also does this, but of late it isn’t happening at all.

    I looked for setting in preferences that might control this but nothing jumps out. Am I just not remembering correctly, or has something changed? Very handy feature that saves a lot of user error :-)

    Kind regards.



  • @appyface said in Invoke find/replace with selection - selection box not marked:

    I could swear NPP also does this, but of late it isn’t happening at all.

    Sorry, not actually able to provide a solution, but there was this discussion a short time ago (and links to earlier discussions). Read:
    https://community.notepad-plus-plus.org/topic/20586/in-selection-grayed-out-in-the-find-replace-box?_=1612813460756

    I’ve been unable to produce the fault on demand, which is what I think is needed to get the attention of the developers.

    Terry



  • @Terry-R Thanks for that link. I think that is different issue, if I reading it right?

    I too have seen the ‘in selection’ box greyed out/can’t mark it of late. And I also haven’t been able to pin down the stituation when that happens. But that does happen a lot for me.

    What I’m asking about is something else. I thought NPP had behaved in past like my other text editor does: Highlight some text in the document, then press CTRL-F. The ‘in selection’ box is marked automatically because text in the document was highlighted first before invoking CTRL-F. And if no text is selected in the document (cursor is between letters so to speak) and press CTRL-F, then the ‘in selection’ box is clear.

    Again, maybe I’m just daft and thought NPP used to behave this way. It definitely doesn’t now and I can’t find any option to switch it on.



  • @appyface

    Here’s how it works: If you have over a certain amount of text selected (I believe it is a thousand or maybe 1024) characters, THEN In selection will automatically be ticked when you invoke a Find / Replace.



  • @Alan-Kilborn Thanks for info. I will check this and get back.



  • Here’s what’s happening for me - 64-bit portable 7.9.3 version.

    1. Invoke CTRL-F with 1025 characters selected and the ‘in selection’ box is automatically marked. (Characters include line delimiters, special characters, etc.) Less than that and ‘in selection’ is not automatically marked.

    2. Once ‘in selection’ is marked, it remains marked for all character selections with CTRL-F regardless of selection length - until CTRL-F is invovked with no characters selected, then ‘in selection’ is automatically cleared. A 1025 character selection is required before ‘in selection’ will be marked automatically again.

    If ‘in selection’ is manually marked, it behaves as in #2 above. If ‘in selection’ is manually unmarked, it behaves as in #1.

    @Alan-Kilborn Thanks for putting me onto the right direction to find out what is happening.

    I’d love to have a simple preference setting that if any text is highlighted, mark the box, if none, unmark the box. But now that I know how it works today, it’s certainly not a deal breaker. Thanks for help and info.


Log in to reply