Registry comment lines wrapping



  • How can I change this kind of behavior, to not wrap multiple comment lines into the previous registry entry but the next entry?
    I was playing around with the langs.xml file in %USERPROFILE%\AppData\Roaming\Notepad++ folder and the line <Language name=“registry” ext=“reg” commentLine=";;" commentStart="" commentEnd=""> and changed it to ex. commentStart="" commentEnd="::" , removing these two and many more, but couldn’t change this. Not possible?

    Notepad++ registry.png



  • @dondolarson ,

    Sorry to be the bearer of bad news. There is no setting to affect that – the behavior of the code folding is defined in the source code of the register-file-type lexer, and is not configurable in the XML configuration files.

    Further, though you may think of the comments as belonging to the next section, technically, a registry-file section starts with the [...] line, not with the comment before it, so it is doing the technically-correct thing, even if that’s not how people normally treat the comments in the registry files.



  • No problem, I understand. It is how it is. Thank you for your explanation and fast reply.


Log in to reply