TIP : Notepad++ not able to save as XML ? - use All Files - and type .xml at the end, it's recognized



  • Good day, I want to save an m3u file to XML, as VLC could only export M3u ,

    but Im trying to get XML for programming project, and I need an XML file - extensible media list, or whatever,

    I looked under E and X, 64bit, latest version,

    looked under a topic here and it was locked

    so then, I just chose all file types, typed .xml at the end and this worked :) TIP for future people :) much love



  • Do you mean save dialog?
    Here it is:
    36bdbbab-5dea-4a9b-bd34-431cba5f5878-image.png

    Also, you can set the language from the menu and it will be saved using the correct file type:
    ec700205-1f3b-4af1-b6a0-a9e47f40a919-image.png



  • While looking at this, I noticed an effect that the Set Save dialog file extension filter to *.* preference setting has on it.
    If that setting is ticked, then when dropping down the Save as type box in the SaveAs dialog, the usual exhaustive list of types (shown in @mere-human 's screenshot) is not shown.

    Of course, for myself, I would never use that long list, because it is a visual hunting exercise and it wastes more time than simply typing one’s desired extension right after the filename, but…it seems like the big list should be shown in this situation?



  • @Alan-Kilborn said in TIP : Notepad++ not able to save as XML ? - use All Files - and type .xml at the end, it's recognized:

    While looking at this, I noticed an effect that the Set Save dialog file extension filter to *.* preference setting has on it.
    If that setting is ticked, then when dropping down the Save as type box in the SaveAs dialog, the usual exhaustive list of types (shown in @mere-human 's screenshot) is not shown.

    Confirmed in my v7.9.4 (and v7.9.3 and v7.9.2). You might want to report that as a bug. Personally, I want text files to default to .txt, so I disable that setting for everyday use… but I would have that that I would notice that while playing with the new *.* setting feature when it was first introduced or bugfixes were added.



  • it only appears for me now at the bottom of the list - as i saved the file in XML already,

    But when I look under alphabetic list - Erlang and ESCRIPT are the only visible E’s and X- for XML features not this beautiful XML :)

    but yeah, it can still be saved as this, despite the listing not being available,
    7.9.4 64bit



  • And on a new file, the extensible mark up appears there,

    testing saving the file as something else, and then again as XML -

    lol now im seeing it everywhere, but is it possible that it’s because i actually used the file format now prior to this??

    in the new save-
    and CTRL ALT S - save as protocol



  • @1MantisPhoenix What plugins do you have? Can you past the info from Menu > ? > Debug info?



  • Also, we are now thinking about re-implementing the Set Save dialog extension filter to *.* preference behavior.
    Your feedback would be very helpful in this issue: https://github.com/notepad-plus-plus/notepad-plus-plus/issues/9515


Log in to reply