Tabs are floating after upgrade to 7.9.5

  • After upgrading to 7.9.5 my tabs are floating in the app container. Any suggestions ?


  • @Dan-Schreck

    This looks like the same problem as (posted after yours)

    I’ve never seen this problem, and am using v7.9.5

    Could you show us the ?-menu’s Debug Info?

    Also, could you try an experiment of downloading the portable version and running it from an unzip directory, and see if the same thing occurs?

  • @PeterJones, Here’s my debug info:
    Notepad++ v7.9.5 (32-bit)
    Build time : Mar 21 2021 - 02:09:07
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 2009
    OS Build : 19042.867
    Current ANSI codepage : 1252
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExport.dll

    When I run the portable version I get the same odd behavior. Just without my tabs (documents):

  • @Dan-Schreck said in Tabs are floating after upgrade to 7.9.5:

    Local Conf mode : OFF


    Could it be something in config.xml that’s remembering the layout of a bunch of plugin windows that are no longer accessible?

    For example, in mine I have:

            <GUIConfig name="DockingManager" leftWidth="297" rightWidth="796" topHeight="225" bottomHeight="193">
                <FloatingWindow cont="4" x="106" y="1003" width="357" height="1042" />
                <FloatingWindow cont="5" x="1073" y="231" width="1880" height="1061" />
                <FloatingWindow cont="5" x="1073" y="231" width="1880" height="1061" />

    Could the portable version he downloaded still be using the global config.xml?

    The image looks like the large margins aren’t really margins, but docking panels that are just partially drawn. Notice the small rectangular boxes with the X.


  • @Michael-Vincent said in Tabs are floating after upgrade to 7.9.5:

    Could the portable version he downloaded still be using the global config.xml?

    @Dan-Schreck would have to confirm, but I believe the Debug Info shown was for the normal installation, not the portable version. If he didn’t delete doLocalConf.xml from the portable directory, and if he really ran the portable version, it should not be using the global config.xml.

    However, as an experiment, @Dan-Schreck could rename %AppData%\Notepad++\config.xml to something else, then re-run the portable (thus making sure that it cannot be using the global config.xml)

    I see that @Dan-Schreck is using a newer version of Windows. Did a recent Windows update cause the problem? I cannot test that, because I am still on an older Windows update:

    OS Name : Windows 10 Enterprise (64-bit) 
    OS Version : 1903
    OS Build : 18362.1256

    Also, @Dan-Schreck , I see you’re on a 64-bit windows; could you try the experiment with a portable 64-bit Notepad++ (the download link for 64-bit is just lower down on the downloads page), making sure that you don’t have any other Notepad++ running at the time, and that the global config.xml is renamed, as described above)

  • Good/Bad News … Good News for me, it’s now working. Bad news for you, I’m not exactly sure why.

    Things I did, all at the same time so I’m not sure what the fix could have been.

    1. Closed all apps i could
    2. Ran CCleaner, including clearing the ‘windows position cache’
    3. Updated my nVidia display driver
    4. Rebooted.

    None of those seem like they should fix this issue, but somehow, they did :)

    For reference … The portable version of the app is fixed too. And when looking at the debug info in the portable app it does say:
    Local Conf mode : ON

    Let me know if you still want me to check something else. But I would say it’s funny that two users had this issue at the same time. There must be some commonality.

  • @Dan-Schreck said in Tabs are floating after upgrade to 7.9.5:

    Let me know if you still want me to check something else.

    Unless you can somehow make yours “break” again, I’m not sure there’s much else you can do.

    There must be some commonality

    I wonder what version of Windows @Colin-Mackie was using. Maybe it was a windows update and/or video driver issue.

    Generally, I no longer trust CCleaner… but maybe when it cleared the “windows position cache” might have helped as well: if Windows stores those positions by app name / internal identifier, then that wouldn’t have changed even with a different version of Notepad++, which might have explained why both installed and portable showed the problem. But given that I can have multiple portable instances which keep their own window size and screen position information separate, I am not sure how.

    Anyway, glad it’s working for you. Happy Notepad++-ing.

  • I’m having the same issue, although I was on an older version of notepad++ when the problem started. I decided to try updating to 7.9.5 but it didn’t help. I am using a Radeon video card, so I doubt the issue is related to nvidia drivers specifically, I’m thinking more of a windows update. I’m only a fully patched Win10.

    Another thing that leads me to believe it is a windows update problem is that I’ve been having odd window rendering issues in other apps too. Microsoft SQL Server Manager Studio is not displaying panels properly, if I try to use the edit table function it displays the panel outside the application window, anchored to the top left corner of my screen, then it will start throwing dialogs about ‘mscorlib.dll’ errors. Then some other apps will not restore correctly after being minimized (slack). I haven’t been putting it all together yet until I decided to check the forum here, so I will be more diligent about collecting information and trying to piece things together. I’ll update if I figure anything out.

  • Uninstalling the following Windows Update resolved the issue for me!

    2021-04 Cumulative Update for Windows 10 (KB5001330) OS Build 19042.928 -

    I am now running on the following and can no longer reproduce the rendering issues in npp or any of the other affected apps (Microsoft SSMS, Slack)

    My working configuration is reporting as follows:

    OS Name : Windows 10 Pro (64-bit)
    OS Version : 2009
    OS Build : 19042.870

  • I had the exact same issue. This morning at 06:30EDT I installed windows updates and today was when the issue started, which was the only change initially and what I believe might have been the source of the issue.

    First I tried a clean install and clearing all registry entries I could find that correlated, which didn’t resolve the issue.
    I found your post and tried updating my Geforce graphics driver first. Post update/reboot the issue was resolved.

    Hope this helps someone else, below is some info on my setup if it assists.

    Win10 Pro 20H2 Build 19042.928
    NVidia GeForce GTX 1070
    Ryzen 7 3800X on X570

Log in to reply