Associate Notepad++ with .txt .log etc



  • I can run Notepad++ as admin, I can choose Settings | Preferences | File Association. I see the 3 columns, the middle one empty, the one on the right has some choices. Those choices are not working regardless of which column I move them to. When I choose a File.txt, File.log etc it runs Windows notepad :(
    If I log on as administrator the choice takes effect, but for only the administrator user, not for my ordinary user account.
    I want association access to Notepad++ from my user account :)



  • @Mick-Dawdy ,

    I can run Notepad++ as admin

    Based on your symptoms, I am assuming you logged in as the Administrator user. When Notepad++ preference dialog told you to Run as Admin, it meant for you to stay as your normal user, but use the “Run as Administrator” that you can get via right-clicking on the executable or right clicking on your shortcut (for a shortcut pinned on your taskbar, it takes right clicking on the icon, then right clicking on notepad++, then choosing “Run as Administrator”). That way, it gives you admin privileges while still being your username, so the settings will be saved in the right location.

    Alternately, as your normal account, just right click on the file, Open With…, then Choose Another App, select Notepad++ and check “Always use this app to open .txt files”. (Note: sometimes Windows fights against this method. Search this forum for “associate” or “association” for more discussions on similar topics.)

    And often there’s an “Edit with Notepad++” or similarly-named entry near the top of the right-click menu, depending on how things went during your original installation… that can be used to open with notepad++ even when double-click doesn’t open it that way.



  • @PeterJones Thank you for the detailed reply, but your assumption was incorrect :( Without going into a lot of detail, there appears to be no way to set it up so that I can simply double click on a txt, log, etc file name to run NotePad++ regardless of my login choice.

    To me this is a major inconvenience, and I see no reason for it. This is just a text editor! It is not a system program that needs to have restricted access.

    I really like this Notepad++ and I have opposite feelings about Win Notepad, and it really annoys me every time I go to use it, which is every day. It should be changed, get rid of all the administrator requirements OR show me the way
    or I might have to join your Haters group :):)
    Mick



  • I’m of the opinion that this part of the Preferences could be removed and I would not miss it:

    f0578f47-ac83-46f4-82ce-b176083f2eab-image.png

    But that’s just me. I presume it works just fine for some people, on some OSes. Actually, I don’t know that it doesn’t work for me, I just know that I don’t need it, so I don’t use it.

    What I do, for a very limited number of file types, is what Peter suggested here:

    Alternately, as your normal account, just right click on the file, Open With…, then Choose Another App, select Notepad++ and check “Always use this app to open .txt files”.

    Simple, direct, easy.
    But I suppose it doesn’t work for everyone.
    It works for me on Windows 10.

    @Mick-Dawdy

    It might help if you shared what operating system you are working under.
    Not necessarily for me (since I don’t do things the way you are trying); but maybe someone else would be able to help better, knowing that.

    Actually, providing Debug Info would be best; see the ? in Notepad++'s menu bar.



  • I missed one of the options. I should have waited a day, settled down, and went at it again. Anyway, all’s good now. Thank you for the patient help :)


Log in to reply