Folder Workspace depth limit?



  • Is there a depth limit on ‘folder as workspace’? This has never happened before, but some folders are not being expanded in folder as workspace. The folders are 6 levels deep. They show up as folders, but I can’t expand them
    is it configurable anywhere?



  • Looks like there definitely is a folder depth limit or possibly a path limit.
    I moved the files a few folders down to work with and they show up fine.



  • @Y-B ,

    It doesn’t seem to be a 6-deep limit:
    4a129536-01c0-4f2f-8791-d4756ac3b209-image.png

    My path name is C:\Users\peter.jones\Downloads\TempData\nppCommunity\FaW\a\b\c\d\e\f\g\h\i\j\k\l\m\m.txt, so 88 characters including the filename m.txt.

    it is possible you’ve hit a character limit in the path name. If you can figure out what that limit is, someone can try to replicate, and see whether you’ve gone beyond MS Windows limits, or whether Notepad++ itself is causing the limit.

    (You might read https://docs.microsoft.com/en-us/windows/win32/fileio/maximum-file-path-limitation?tabs=cmd, where it explains that each path element (folder or file name) has a 260 character limit; there is a registry key that they mention in that doc which you can set to enable long path names – you might see if that helps your problem. Also, per that doc, the total path string should be able to go up to 32k, but I am guessing most applications set limits on their string size before hitting that length.)



  • Just checked. the path length is 166 characters (all English). The longest file would bump it to 195 characters



  • @Y-B

    Can you do an experiment like the one I showed, including showing your debug info (found in ? menu, Debug Info), and paste the screenshot here? And then try changing some of the folder names to be similar to your environment where it’s not working.

    Because, as I’ve shown, it works for me. And we cannot help you debug if you cannot show us how it doesn’t work for you.


Log in to reply