New Documents Saved As PHP Can Not Be Saved Again



  • Can anyone confirm this as a bug? I think it has something to do with using “Save As” instead of “Save” and PHP files (maybe other types too, but not normal text files).

    Steps to reproduce:

    1. File -> New
    2. Add some text
    3. File -> Save As
    4. Change file name to end in “.php”
    5. Change file type to “PHP Hypertext Preprocessor file”
    6. Save
    7. Add some more text
    8. File -> Save is greyed out. An asterisk is not added in the window title bar indicating the file has been edited.


  • Hello Web4Guru,

    I followed your method, step by step, on my old Win XP laptop, with the last v6.8 portable N++ version, simply located in a C:\_680 folder

    Unfortunately, ( I mean for you ), each time I added some text, after the initial text, to my PHP test file, the icon became red, with an asterisk in front of the absolute path and the menu option Save was normally available and NOT greyed out !

    Right now, I can’t understand the reason why :-( May be, changing PHP file’s location would help ?

    Good luck for investigation !

    Best Regards,

    guy038


Log in to reply