Unable to Install plugins from plugin Manager in Notepad 7.9.5



  • Even after click the install button looks like installing and my notepad++ does re-launch, but nothing happen.
    1a8e721d-5db5-4e16-a5fe-6d69efa09b74-image.png



  • maybe :
    1- the plugin is x86 and your npp version is x64 (or the opposite)
    2- the plugins are on https://sourceforge.net and it is forbidden in many countries
    3- the plugin is not compatible with npp version
    so first try to use vpn and download it from plugins admin if not work download the correct version x86 or x64 from here :
    https://sourceforge.net/projects/npp-plugins/files/XML%20Tools/Xml%20Tools%202.4.9%20Unicode/
    and install it maunly
    note that the folder name must be as the dll file name otherwise the plugin will not work



  • @Raja-Siva said in Unable to Install plugins from plugin Manager in Notepad 7.9.5:

    Unable to Install plugins from plugin Manager in Notepad 7.9.5

    The application is called Notepad++ – those ++ symbols differentiate it from the Microsoft tool notepad.exe that is bundled with Windows.

    The Plugin Manager isn’t involved with Notepad++ v7.9.5. It’s the Plugins Admin, as clearly indicated in your screenshot.

    (The terminology is important, because we still occasionally see people who have just updated from an ancient Notepad++ that still used the Plugin Manager plugin to manage plugins, and were confused with the modern versions that have the built-in Plugins Admin instead.)

    my notepad++ does re-launch, but nothing happen.

    What do you mean by nothing happens?

    Does that mean that the XML Tools does not end up as a submenu in plugins menu? You can see it near the end of my menu, here:
    60cdfb1e-d11d-4b41-bbdd-3937fae48116-image.png

    You should look at your ?-menu’s Debug Info and copy/paste that data into your reply here. That will tell us some critical things about your setup, including whether you are on v7.9.5-32 or v7.9.5-64, and what other plugins are correctly installed. That will also tell us where your Notepad++ is installed, and thus where you should expect to see installed plugins.

    For example, if Debug Info shows that notepad++ is installed in c:\Program Files\Notepad++\notepad++.exe, then you would expect the plugins to be in the c:\Program Files\Notepad++\plugins\ subdirectory; and specifically, if it installed correctly, the XMLTools plugin will be in c:\Program Files\Notepad++\plugins\XMLTools\XMLTools.dll. If it’s not there, something apparently did go wrong with the installation. (You can also get to the plugins directory from Notepad++ itself using Plugins > Open Plugins Folder…, the last entry showed in my Plugins menu screenshot.)

    If the plugin is really not there, then maybe you are behind an I.T. installed firewall and need to set up a proxy – the ?-menu’s Set Updater Proxy command actually sets the proxy for Plugins Admin downloads, as well. See here for more suggestions (from me) regarding Proxy settings and other write-permission issues that make Plugins Admin not install a plugin. Or this post by one-time regular @Meta-Chuh, who showed some screenshots of how to setup the proxy – specifically on an XML Tools question, coincidentally. Or search the forum for more instances.

    If it’s not proxy, then as I said in the other post, you might need to run Notepad++ as Administrator to elevate privileges. Or you might need to just add yourself write/create privileges to the Plugins folder in Windows Explorer > Right Click > Properties > Security > Edit or Advanced.

    ------------

    @Abed99,

    Your response was well-meaning, I am sure. However, I need to address some things:

    1. Plugins Admin does not accidentally install x86 vs x64 – it will only ever grab the right version for your version of Notepad++
    2. XML Tools v3.1.1.1 is hosted on github (https://github.com/morbac/xmltools), as a quick check in Plugins Admin will show you, so that’s not the problem. 1254b672-ca23-478c-958a-9d7f2a6cfb29-image.png
      And thus, using a VPN isn’t likely to improve things (unless the OP’s country or IT department is also blocking github, which isn’t unheard of).
      Further, the XML Tools v2.4.9 you linked from sourceforge is years out of date (Oct 2016, vs 3.1.1.1 from Jan 2021 which is the most recent version linked from Plugins Admin in NPP v7.9.5, or v 3.1.1.5 available on github)
    3. XML Tools is compatible with Notepad++ v7.9.5 (I have it installed in mine, for example)
    4. And while it is important and true that “the folder name must be as the dll file name otherwise the plugin will not work”, again, the OP will not have that problem because as was shown in the screenshot, they are using the Plugins Admin to do the installation, which automatically puts plugin DLLs in the right folder.


  • @PeterJones great informations
    Thank you for the correction



  • @Abed99
    Created XMLTools folder and copied the dll, but it gives the following error.
    46cc85d4-41e1-44d3-8aa3-19a869107b57-image.png

    Following is my Notepad++ Debug Info.
    Notepad++ v7.9.5 (64-bit)
    Build time : Mar 21 2021 - 02:13:17
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 1909
    OS Build : 18363.1500
    Current ANSI codepage : 1252
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll



  • Downloaded the copied the files into plugins folder as well. Even I tried the Settings–>Import–>Import Plugins
    c7951e6f-26e6-444d-9645-2abd037d80a8-image.png



  • delete the old one and download this
    https://github.com/morbac/xmltools/releases/download/3.1.1.5/XMLTools-3.1.1.5-x64.zip
    Install it and it should appear here:
    1.jpg



  • @Abed99 said in Unable to Install plugins from plugin Manager in Notepad 7.9.5:

    https://github.com/morbac/xmltools/releases/download/3.1.1.5/XMLTools-3.1.1.5-x64.zip

    Thanks a lot. It worked perfectly. How do I correct Plugin Manager.
    Because I need to install JSON Viewer, Compare etc…



  • @Raja-Siva said in Unable to Install plugins from plugin Manager in Notepad 7.9.5:

    How do I correct Plugin Manager.

    As I said already, it’s not the Plugin Manager, which hasn’t worked with Notepad++ for years. It’s the Plugins Admin, as your screenshot clearly showed.

    And there’s nothing to correct: as far as I am aware, the Plugins Admin works just fine. Either you need to set your proxy, or you need to fix your permissions, or if you’re in some very strange networking situation you will have to manually download the plugins and install them yourself. But Plugins Admin works as designed, and nothing you have shown indicates there is anything wrong with it. If you can show that Plugins Admin is doing something wrong, then we’ll work with you to ask the developers to correct the problem; but you haven’t shown that yet.


Log in to reply