Tab Size, Tab Font, and Tab Background Color Problem



  • In the Styles Configurator, my theme is the default (stylers.xml). The style is set on Global override. My background is orange and the text is black. The foreground is deactivated.

    The problem is that I got the active tab text to change, but I can’t get the active tab background to work. Both the text and background color works for an inactive tab.

    And another issue is that I don’t see a way to enlarge the tab text and make the tabs larger. I have to get close to the screen to be able to clearly see what the tabs say.

    My main font is set to Georgia 24. Having the tab font the same (or larger) would make it easy for me to see the tabs.



  • @Troglo37 said in Tab Size, Tab Font, and Tab Background Color Problem:

    but I can’t get the active tab background to work

    As far as I remember, this has never worked in Notepad++.
    I’m not sure why? Anyone else?
    I mean, if it isn’t going to work , why wouldn’t the Background color control be disabled?
    TBH, it is just something I’ve gotten used to (it NOT working).

    I don’t see a way to enlarge the tab text and make the tabs larger.

    About the only way would be to UNTICK this in Preferences > General > Tab Bar :

    acb8f338-1dbe-480f-91ba-4767068990fa-image.png



  • This post is deleted!


  • Sorry,

    I think I completely misunderstood things. Deleted the old post, because most was irrelevant

    Reading @Alan-Kilborn’s reply,

    As far as I remember, this has never worked in Notepad++.
    I’m not sure why? Anyone else?

    … I realized that @Troglo37 might have meant the Global Styles > Active tab text setting. I don’t think I’ve ever actually looked at that one, other than when I was confirming the “[foreground only]” for the usermanual’s “Global Styles” section.
    e82687b4-69a7-48c5-97c2-65352bd4ab45-image.png

    I mean, if it isn’t going to work , why wouldn’t the Background color control be disabled?

    Please note that in v8.1, the background colour is greyed out/disabled, trying to make it obvious that it’s a style that sets foreground-colour only (I forget what version that started in… but I just checked a fresh portable as far back as v7.8.0 from Oct 2019, and the background color box was disabled then, so it’s been that way for at least 1.5 years).

    But maybe I’m still not understanding what you’re talking about.

    From the old post, further details on the tabbar text size

    For the filenames on the tabbar text, there isn’t much you can do; the Settings > Preferences > General > Tab Bar > ☐ Reduce toggles between small text (when checked ☑) and slightly larger text (when unchecked ☐) – but I’m not sure that unchecking it will make it big enough for you, if 24pt font is what you prefer for reading.

    ☑ Reduce checked 76bce17e-6a91-4012-b6b6-e0fd341ad7dc-image.png
    ☐ Reduce not checked 75d3c8ce-17f7-4e4e-a534-2a4757d73d6a-image.png

    There are Windows OS settings that you might be able to find that might influence the font size for the tabbar text, but each version of Windows is slightly different on where to set those (you might be able to find some hints by searching for “control panel” or “system font size” or some such in the forum – I know there have been other discussions of Windows-based settings that influence Notepad++ GUI font sizes).



  • @PeterJones said in Tab Size, Tab Font, and Tab Background Color Problem:

    For the foreground and background colors on the “active” vs “inactive” tab, I’m not sure I’m fully understanding what your issue. Maybe if you showed pictures of what you have and somehow indicate what you want instead.

    It appears I was off-base with these earlier comments:

    As far as I remember, this has never worked in Notepad++.
    if it isn’t going to work , why wouldn’t the Background color control be disabled?

    I see that in a fresh 8.1 portable, the Background colour controls ARE disabled for Active tab… choices.

    For some reason, in my much-migrated-thru-versions daily use configuration, these controls are actually enabled.

    Thus, it appears the bottom line is that you just can’t change the background color of active tabs, only inactive tabs.
    It is still odd, but maybe there’s a reason for it.

    EDIT: It appears I quoted Peter BEFORE he removed most of his previous posting. Hehehe.



  • @PeterJones I’m currently using version 7.9.5 64bit. Under “Global Styles”, in the Style section, the three Active tab settings are all enabled. They are not grayed out.

    If changing the background tab color, changing the tab font size, and tab size don’t currently work, should a bug report be filed?



  • @Troglo37 said in Tab Size, Tab Font, and Tab Background Color Problem:

    @PeterJones I’m currently using version 7.9.5 64bit. Under “Global Styles”, in the Style section, the three Active tab settings are all enabled. They are not grayed out.

    I didn’t say that the three Active Tab styles were disabled. I said that the Background Colour on the Active Tab text style was disabled. In fact, here’s a quote of exactly what I said:

    @PeterJones said earlier,

    Please note that in v8.1, the background colour is greyed out/disabled

    And here’s a screenshot from a fresh unzip (no customizations) of v7.9.5-64bit portable showing this to be true:
    adc6508e-36b5-45c6-96af-b4aa1e27d825-image.png
    The same is true on the other two Active Tab styles (screenshots not included)

    The fact that those three are all foreground-color-only settings is also clearly documented in the online user manual, in the section on Global Styles: 56917fe8-ed20-486d-9603-cf5eaa4c4c08-image.png

    @Troglo37 also said,

    If changing the background tab color, changing the tab font size, and tab size don’t currently work, should a bug report be filed?

    No. Because it’s working as designed and documented, so it’s not a bug. You could make a feature request to add foreground colour and/or font face/size settings to those three… but it’s not a bug, so don’t call it a bug report.



  • @PeterJones said

    I didn’t say that the three Active Tab styles were disabled. I said that the Background Colour on the Active Tab text style was disabled.

    Sorry about that. I misunderstood.

    @Troglo37 also said,

    If changing the background tab color, changing the tab font size, and tab size don’t currently work, should a bug report be filed?

    No. Because it’s working as designed and documented, so it’s not a bug. You could make a feature request to add foreground colour and/or font face/size settings to those three… but it’s not a bug, so don’t call it a bug report.

    Thanks. I made a feature request. I hope I filed it correctly. Here’s the link. https://github.com/notepad-plus-plus/notepad-plus-plus/issues/10070


Log in to reply