Preventing "TEST" + {TAB} from being auto-completed into "TESTING"



  • I only use Notepad++ for a handful of text documents. One of them helps me keep track of my work in progress on a personal project. Depending on how far along I am on that task, a line of text in my document will start with OPEN, TEST, DONE or SKIP. After typing that word, I press the TAB key and enter a brief task description starting on column 9. Whenever I type TEST and press the TAB key, the Notepad++ autocomplete changes TEST to TESTING. At the moment, my workaround is to type TEST, followed by a space, followed by the TAB key. That works, but it’s a bit annoying. Is there a file I can edit so that I can either remove TESTING from the autocomplete list or just change it to TEST? I found “testing/S” in en_US.dic, but changing that to “test/S” did not resolve my problem.



  • @Dean-Lesner ,

    TEST{TAB} does not autocomplete to TESTING on a fresh unzip of v7.9.5-64bit (portable) or in my standard install of v8.1. In the portable 7.9.5, I installed the DSpellCheck and its en_US dictionary, and that didn’t change the behavior. (I tried the DSpellCheck, just because you mentioned it, but its spellcheck dictionary is not used for Notepad++'s auto-completion, and I don’t think that DSpellCheck itself hooks into the auto-completion feature of Notepad++.)

    The only way I can replicate your problem in this setup is if there is the word TESTING someplace else in the document, but not the word TEST.

    Thus, either you have non-standard settings somewhere, and/or you have some other plugin that is influencing the auto-complete. If you show us your ? menu’s Debug Info, as well as a screenshot of your Settings > Preferences > Auto-Completion, and we might be able to offer insight (that will tell us not only your exact version of Notepad++, but also what plugins you have installed)

    AFAIK, there is no way to remove a specific word from the auto-completion list, because the default just uses words in the current document, and words specific to the current lexer (programming language)

    Workarounds:

    • You could type TEST{ESC}{TAB}, which will take you out of auto-completion mode before hitting the TAB
    • You could use Auto-completion settings, and change the #-characters to something 5 or higher (so that TEST isn’t enough characters to trigger auto-completion)
    • You could use the Auto-completion settings to turn off word completion (either by selecting Function Completion, or by unchecking Enable auto-completion on each input)

Log in to reply