Foreign character cannot display in pop up window Notepad++



  • I am using Notepad++ in Ubuntu desktop, I got Chinese font display properly in the Notepad++ window, but when I open up the find window (ctrl+F), Chinese font cannot display, all other foreign also cannot display except English, what should I do?

    I have tried to change the style preference in Notepad++, but it does not work for me, Google also come with no answer.

    Screenshot



  • @HK-Kongou ,

    It works for me. (I used google translate to generate some Chinese text, This is example text. => 这是示例文本。 for the document text and the FIND string, and It will be changed => 它会被改变 for the REPLACE string)

    f16f8a50-3766-4e7f-8268-443bf7cca793-image.png

    It properly matched and replaced for me, and displayed.

    What version of Notepad++ are you using? (copy/paste your ? > Debug Info results here – mine are in my screenshot). Also, if your Notepad++ is new enough to have Settings > Preferences > Searching > ☐ Use Monospaced font in Find dialog checkbox, what is the state of that (or, better, paste in a screenshot of that whole page of settings)?

    I tried seeing if the Settings > Style Configurator > Global Styles > Default Style would affect the Find/Replace dialog font, but it doesn’t; I don’t know what font is used in that dialog (probably a system font defined by your OS settings) – but maybe whatever font was chosen for that dialog on your machine doesn’t know the Chinese characters you are trying to use.

    Given your screenshot, with the nine-dot icon where I’d expect a Windows “start menu”, and the linux penguin on the toolbar, I am wondering whether you are using Notepad++ on Ubuntu or other linux-based OS through WINE or equivalent; if so, you may be running into a limitation of the design decisions on WINE or equivalent when they translate win32-api calls to linux-compatible UI calls. (But this was just a guess, so if you’re really just in a highly-customized Windows OS, sorry for the misinterpretation.)



  • I said,

    Given your screenshot, with the nine-dot icon where I’d expect a Windows “start menu”, and the linux penguin on the toolbar, I am wondering whether you are using Notepad++ on Ubuntu or other linux-based OS through WINE or equivalent; if so, you may be running into a limitation of the design decisions on WINE or equivalent when they translate win32-api calls to linux-compatible UI calls. (But this was just a guess, so if you’re really just in a highly-customized Windows OS, sorry for the misinterpretation.)

    But you had already said,

    I am using Notepad++ in Ubuntu desktop,

    Sorry, by the time I wrote my reply, I forgot you’d said this. So yes, whatever font choices and translation between Notepad++.exe thru WINE into Ubuntu is getting messed up.

    Please note that Ubuntu installer (which goes through WINE or equivalent) is not released by the developers; Notepad++ is a Windows OS application, and linux installations are not officially supported by the Notepad++ developers. The fellow users in this Community are happy to tell you how things should work in a true Windows environment, but we don’t necessarily have the expertise to answer all the oddities introduced by the WINE-or-equivalent translation layer.



  • @PeterJones said in Foreign character cannot display in pop up window Notepad++:

    What version of Notepad++ are you using?

    Must be relatively recent as Find in Projects tab is in the Find window.
    (Just stating this because I was about to ask if OP was using some ancient version when I noticed this.)



  • @PeterJones hello:
    Debug info
    Notepad++ v7.9.5 (64-bit)
    Build time : Mar 21 2021 - 02:13:17
    Path : Z:\home\kelvin\snap\notepad-plus-plus\260\notepad-plus-plus\notepad-plus-plus.exe
    Admin mode : ON
    Local Conf mode : OFF
    OS Name : Microsoft Windows 7 (64-bit)
    OS Build : 7601.0
    Current ANSI codepage : 1252
    WINE : 5.0.3
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExport.dll

    The windows 7 should be fake due to WINE, it should be ubuntu20.04 LTS



  • @HK-Kongou ,

    As I said in my follow-on post, the culprit is likely the WINE translation later. I don’t know if there’s a way to tell WINE to pick a different font for windows dialog boxes, but if there is, maybe picking a different font will help you.

    Or maybe turning the checkmark on for Settings > Preferences > Searching > ☑ Use Monospaced font in Find dialog will help, because that will pick your monospaced font rather than the normal dialog font – and maybe that font has the Chinese glyphs you need.

    Unfortunately, I have no experience with WINE, so I don’t have any more ideas.



  • addendum: I don’t know whether WINE mimics the Win7 or Win10 settings dialogs and registry, but https://www.askvg.com/tip-how-to-change-fonts-of-menus-dialog-box-and-other-text-in-windows-8-and-later/ explains how to change system dialog fonts in Win7 and Win10.


Log in to reply