Cannot disable tab to space



  • Hello,
    I have installed the new version 8.1.2 64 bit on Windows 10. I can not disable Settings>preferences>Languages and then the Replace by space option. The hook is set or unset but in the editor tabs always get replaced by spaces. How can I disable this?

    Thank you

    Notepad++ v8.1.2 (64-bit)
    Build time : Jul 16 2021 - 01:59:50
    Command Line :
    Admin mode : OFF
    Local Conf mode : ON
    Cloud Config : OFF
    OS Name : Windows 10 Pro (64-bit)
    OS Version : 2009
    OS Build : 19042.1110
    Current ANSI codepage : 1252



  • @Markus-Hirsch said in Cannot disable tab to space:

    The hook is set or unset but in the editor tabs always get replaced by spaces. How can I disable this?

    Based on your description, I’d say you either set the hook for one language and are using another, or you set the hook for the generic [Default] language but that the language you are actually using does not honor that setting.

    The [Default] is set to replace-with-space, but when Language > M > Makefile is active, it still uses tabs:
    550b213c-5d42-4b59-985f-f51566cdc6e0-image.png
    This is because the Makefile setting in the Languages prefererences does not use default value and is not set to replace-by-space
    a2a364a8-bf13-408d-9a4d-7ff207957a83-image.png

    If I change that to use default, then even in Makefile it will use spaces instead:
    34e27527-64ab-4351-a4db-fa3732b622a4-image.png

    So you have to have the right combination. The important details are which Language is selected for the active file, and how the combination of the Tab settings for that language interact with the tab settings for the [Default] language.

    (If the lower-left of the status bar is “Normal text file” and the Language menu indicates None (Normal Text), then the file will follow [Default]; for any other language, it will follow the settings for that language)



  • I see, thank you. I am using python and it says python file in the lower left. So how can I edit that setting for python?



  • @Markus-Hirsch

    So how can I edit that setting for python?

    Wouldn’t you think you’d do it by making this selection and then changing the settings below it?:

    54af3af5-159d-46b2-af89-53a2bc3b4f8c-image.png



  • Dam it, it was too simple. Thanks!
    Works now.


Log in to reply