Notepad++ update error (schannel)

  • schannel: next InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE (0x80090326). This message comes trying to update Notepad++ v8.1.2, it happens on 1 computer only. I will appreciate to have a lead to resolve the error.

    Here is my Debug Info:

    Notepad++ v8.1.2 (64-bit)
    Build time : Jul 16 2021 - 01:59:50
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : ON
    Local Conf mode : OFF
    Cloud Config : OFF
    OS Name : Windows 7 Professional (64-bit)
    OS Build : 7601.24546
    Current ANSI codepage : 1252
    Plugins : mimeTools.dll NppConverter.dll NppExport.dll

    curl error

  • @aimi617 ,

    Given the “initializesecuritycontext”, I am thinking that Notepad++ is having a hard time asking the OS for the elevated privileges needed to do the update.

    Also, if your debug info is correct and you already have v8.1.2 installed, why are you still trying to update? That’s already the newest-released version … and in fact the auto-updater is still looking for v8.1.1, so it shouldn’t even try to install anything.


    • Are you really trying to update starting at v8.1.2? Or did you really start the process from an earlier version of Notepad++ (and if so, which version did you start from)?
    • Did you use ?-menu Update Notepad++ ? Or did you manually download the v8.1.2 installer and run it?
      • If running from Update Notepad++ menu entry, did it ask you to elevate permission? Or were you already running Notepad++ in Admin Mode when you launched Update Notepad++?
      • If running the downloaded installer .exe, did you run it normally or did you use “run as administrator” to give it elevated privileges for installation?
    • Or are you saying that you’ve already updated to v8.1.2, but when you try to run after completing the installation, it gives you that error?

    Using a search engine on your error message shows that other people have similar error messages in many other applications, and at least one page showed that the error happened with Win7 but not with Win10 when trying to access a website via HTTPS from inside the application. That makes me wonder if the developer changed something in gup.exe or updated libcurl.dll to a version that isn’t compatible with Win7 anymore… I don’t have any Win7 machines to test on, unfortunately. If no one else has been able to help you further, maybe I’ll see if I can find my Win7 virtual machine later this week or this weekend, and see if I can replicate the problem.

    In the mean time, please supply the answers to the questions I’ve asked, and anything else that will help us replicate the exact process you followed that caused the error.

  • It doesn’t matter which version of Notepad++ is installed, the same error happens with earlier versions, I tried v7.9 as well as other v7.x versions, all 64-bit. I guess the culprit is somewhere in Windows Registry but to find the exact key/value, it’s like needle in a haystack. Most probably some 3-rd party service or app changed security settings where Notepad++ update is failed.

    The first installed Notepad++ was v8.1.1 then an attempt to update manually through the ?-menu instantly gives that pop-up error message. Elevate permission by default is admin, UAC is off and all apps automatically start under admin privileges.

    In comparison, v8.1.2 is installed on other 2 computers under Win7 and 10, absolutely no problems to update manually through ?-menu.

  • @aimi617 said in Notepad++ update error (schannel):

    Most probably some 3-rd party service or app changed security settings

    Unfortunately, there is nothing we can do to fix security settings on your PC. I am sorry.

    If you are able to manually write to C:\Program Files\Notepad++\, you might be able to bypass the installer. For writing to that folder, you might have to run Windows Explorer as Admin… or when you paste into that folder, Explorer might ask you for Admin permission). So can download the portable 64-bit NPP v8.1.2 zipfile from the official downloads page and open up the zipfile; then manually copy the executable and the associated config files and plugin/updater DLLs from the zipfile into the appropriate location on the problematic computer (C:\Program Files\Notepad++\ and subfolders).

  • Thanks, I will mean it, actually installation from the full installer works well and doesn’t cause the problems.

Log in to reply