setting npp as the default of text files in Windows 7



  • setting npp as the default of text files in Windows 7 doesn’t work any more. It use to work but now it doesn’t. I tried reinstalling npp but that didn’t help. npp itself runs just fine and drag and drop also works.



  • Have you tried “Open with” from the explorer context menu of a text file and told Windows to always use NPP to open these files?
    This always works for me.



  • @Donald-Bellefuil ,

    Normally Win7 is better behaved in regard to associations than Win10 is, so that surprises me.
    As @Stefan-Pendl said, definitely try “Open With” – you may have to browse to the Notepad++ location.

    Another thing you can try is to close Notepad++, and right click on the shortcut or .exe and “Run as Administrator”, then go to Settings > Preferences > File Association and add extensions to the “registered extensions” panel in that dialog (this should change associations in the registry). Then exit Notepad++; since registry changes were made, you will sometimes need to log out of your computer or even reboot, to get those changes to take effect. After that, see if those extensions are now properly defaulted to Notepad++.

    If you had recently changed from 32bit Notepad++ to 64bit Notepad++, some of the associations in the Windows registry might not be pointing to the right path for notepad++.exe anymore. You might need to use regedit to go looking for notepad++.exe, and make sure it always points to the right location.



  • I had to change the registry per your suggestion. Thank you.


Log in to reply