Single quote character



  • Ever since I used Notepad++ to edit a file the other day the single quote character I get within VB6, and even in here, is now ` (not ’ ). I’ve searched the registry and online for clues to no avail . How can I get ’ back as I need it for the VB6 comment character?



  • This might be due to the usage of a different font. Mono spaced fonts should always display the comment character as '.
    ´ and ` are not '.



  • I have never changed the font in Notepad++ or in Windows, so if this is the cause then it must have been done by the last update of Notepad++.

    I have tried a couple of fonts in Windows 10 Settings (Courier New and Ariel) but I still get the same character.

    How do I change the font in Notepad++?



  • Traced to a dodgy keyboard - a couple of keys were giving out the wrong characters. The Notepad document change must have happened at the same time.



  • @Ian-Whyte said in Single quote character:

    How do I change the font in Notepad++?

    Settings > Style Configurator > Global Styles > Default Style > Font
    (see style configurator documentation)

    And as you discovered, it’s not likely a font issue: I have never seen a font where ASCII 39 single-quote ' is rendered the same as ASCII 96 back-tick/grave-accent ` and as Stefan said is also different from the Unicode U+00B4 acute accent ´. (And none of these should not be confused with the ‘smart single-quote’ characters and which this forum will convert unprotected single-quotes into if you’re not careful). But in Notepad++, if you keyboard is set up as normal, and you don’t have Windows configured to map that key to a different character, then typing a single-quote-key on your keyboard should give you ' in Notepad++.


Log in to reply