Notepad++ stuck in administrator mode [Solution]



  • Stuck in Notpad++ wanting to get admin rights endlessly, drag & drop failures, context menu annoyance, broken flow? So, there’s a few discussions about this and the forum warned me of not reviving any old thread - hence the new thread.

    I had Notepad++ run as admin. Don’t go into registry or open up Powershell or cmd or something linuxy like that, it’s just a checkbox.

    • Right click on the executable or your shortcut to it
    • Select Properties -> Compatibility -tab
    • Uncheck the box next to “Run this program as an administrator”

    No more permanent admin mode :) Attached is an image from a finnish version running Win10 Home. Yeah I don’t like localization, either. But I gotta be versed in the finnish version as everyone uses it here in Finland. When giving tech support I must know what the client sees as exactly as possible.

    Bai!

    notepad_adminmode_.PNG



  • @Mainio-Mooses ,

    Thanks for sharing that.

    For those who cannot read Finnish:

    f6f0dc23-a7db-4644-b9ec-58bdf1c74c52-image.png

    It should be noted that some of those previous threads also mentioned that setting, but it wasn’t always sufficient for some users’ situations.



  • Should we add this somewhere into the user’s manual?



  • @mere-human said in Notepad++ stuck in administrator mode [Solution]:

    Should we add this somewhere into the user’s manual?

    Interesting thought. Selecting Administrator mode or not, and whether your shortcut or executable have that selected, is really more of a Windows OS question, not a Notepad++ - specific question.

    But if you had a good idea where in the manual to put it, I wouldn’t immediately reject an issue to add that (especially if it came with an accompanying PR).


Log in to reply