Only manual highlighting?



  • I’ve used and loved Notepad++ for years. I do the updates when they are offered. But since the 8.1.4 update the highlighting on selected doesn’t show up. I don’t need anything fancy, but if I double click on a word or try and drag select text, I can’t tell if it’s selected or not. Now if I right click on that text and click on style token and choose one of those five, then it highlights, and I can tell if I got the text I wanted or not. also if I search for something the result is not visibly selected.

    This is all new behaviours, I’ve searched the preferences and style configuration.

    Any help greatly appreciated.



  • Are you sure ‘Smart Highlighting’ is enabled in the [ Preferences > Highlighting ] menu?
    Highlighting.jpg



  • @artie-finkelstein Yes, I’ve tried it both ways, Just tried it again, still no joy



  • @Michael-D-Doubet
    My thoughts next go to the setting for Smart Highlighting in the [ Settings > Style Configurator… ] menu. If it’s too similar to the main Background colour as determined by the Colour Style selection under the enabled Global, Default, or language based settings (which depends on your selection of Language: and then Style:), the markings for other matching words will not be obvious after double clicking, only the currently selected word will be marked. I’m sorry if that description is a bit convoluted, but I have no idea what theme (if any) and language (if any) you have selected for the file you are editing.

    Note: Changes in the Configurator are visible as they are made, but are only made persistent when you select Save & Close, Notepad++ will update the affected file when it exits.



  • My settings are about as basic as you can get. English, black text on white background. The only change was running the update to 8.1.4. I wonder if I got a corrupted file? Anyway I think it’s time to uninstall and reinstall Notepad++? Maybe stopping at 8.1.3



  • @Michael-D-Doubet said in Only manual highlighting?:

    The only change was running the update to 8.1.4.

    So if the change occurred immediately after upgrading to 8.1.4 then I think your assessment of a corrupted file might be a good first step. So once you have uninstalled Notepad++, go into the Program Files (or Program Files x86) folder and remove the Notepad++ folder. Also go to %appdata% (you can type that into the search bar line) and it takes you to the hidden folder where configuration data for Notepad++ may also reside. If that folder exists you should remove it as well.

    Be aware that these steps will remove any customizations you have created, so consider it before deleting the folders.

    Terry



  • The uninstall without saving custom settings and then reinstall seems to have worked. My normal selecting highlighting appears to be back.

    Thanks for the help.


Log in to reply