Page-down scrolls everything off the top of the window



  • When I hit Page-down, the cursor jumps down a page… but then everything scrolls down to make the line in which the cursor ends up the top line in the window. So everything above this line is scrolled away. It would be much better if the window only scrolled far enough so that the currently active line is visible.

    An example - note my cursor is at the beginning of line 1:
    npp1.png

    I hit Page-down (no Shift, no Alt, nothing) and get this:
    npp2.png

    Line 2 is now the top line, and line 1 has been scrolled up out of the window. Doesn’t make sense to me. Of course the cursor should now be in line 2 - but line 1 should still be visible.

    I don’t see anything I broke in the settings:
    npp3.png

    I’m running Notepad++ v8.1.4 (64-bit) on Windows 10.



  • @StephanKolassa

    Try menu Settings => Preferences… => Editing and then untick “Enable scrolling beyond last line”

    cc8bf600-60ee-4f3f-bc05-bb5cf6486bd1-image.png

    Cheers.



  • @StephanKolassa

    PageDown implementation is handled in the Scintilla IP component, and it works the way I expect it to. If you have more than a page worth of text, and your cursor is partway through the visible page, then page down moves the view so that the last visible line of the current page becomes the first visible line of the next page, and the cursor stays in the same location relative to the top.

    b18188db-e28d-49df-99ff-c58fe11bb742-image.png => 4d379061-0a0e-403f-a0db-7d8a57b4c668-image.png

    (in my picture, there were 19 visible lines, with cursor on line 4. after PageDown, rows 19-37 are visible, with cursor on the fourth line, which is 22)



  • @Michael-Vincent Thanks for that fast reply! That did the trick!


Log in to reply