Opening .CFM files



  • Hi, I’ve just installed Notepad++ v8.1.5 and have been trying to open a simple .cfm file. Notepad++ says it’s not responding and then closes. Can anyone help?



  • @Pete-Lucas ,

    “Not responding” generally means either the OS or CPU is overwhelmed – either because Notepad++ itself is using too many CPU cycles (which I almost never see except in giant regex searches, though other people occasionally report it) or because another app is taking so many cycles that Notepad++ gets only occasional cycles and cannot complete normal tasks. So you would have to do things like look at the Windows OS tools Task Manager and/or the Resource Monitor to see how much CPU is being used by other apps vs. Notepad++.

    Often, people report Notepad++ slows down (or stops responding) when it’s trying to do a big search-and-replace (which isn’t what you’re doing, since you’re just loading a file). Or if it’s a humongous file (>100Mb) and it’s trying to do a lot of syntax highlighting – but since your file type is .cfm, and Notepad++ doesn’t by default have a syntax highlighter associated with that filetype, so that’s probably not it. (Also, you say “simple”, so I am assuming small. Is .cfm a ColdFusion Markdown file for you? That’s what a quick search for that file extension guesses, but you don’t tell us.)

    You might have a plugin that’s trying to do something with a .cfm file. If you shared your ?-menu’s Debug Info, it would tell us what plugins you have installed. And if you wanted to try with the -noPlugin command line option, it would disable all plugins… if -noPlugin makes it suddenly work 100% reliably, then you’ll want to go through and figure out which plugin is causing the slowdown.

    Alternately, maybe the .cfm file was on a network drive or a shared drive (so that it had multiple people accessing, or you are accessing across a network), or maybe some other medium that was being slowed down because some other application was accessing the drive at the same time, not allowing Notepad++ to correctly read the file.

    Or maybe you had a file from a network or shared drive in your Recent Files History; if so, go to Settings > Preferences > Recent Files History and check the checkbox for “Don’t check at launch time”, which as explained in the manual will avoid checking if files in the Recent Files History still exist.

    Mostly, you’ve given very little to go on, so I had to make guesses based on the normal causes of slowdowns. There is nothing inherent about the .cfm file extension which causes Notepad++ to stop responding, so the problem is likely somewhere else … and the hints above will help you try to solve or workaround the problem.


Log in to reply