Synchronize Scrolling with Word Wrap



  • Hello. I was wondering how to force the synchronize scrolling option to synchronize to the line number, rather than to the displayed lines when using word wrap.

    As it is now, the files will be synchronized to only the line displayed, which defeats the entire purpose of synchronized scrolling when, for example, one file has numerous lines that use the word wrap feature but the other file doesn’t, extending the displayed length of that single line number for one file but not the other.

    The files very quickly become desynchronized because they are only following the displayed lines, not the line number as I would expect. I did a quick forum search, but couldn’t find a post about this subject, so I figured I’d ask here. Is this function possible at this time, and if so, how would I set it to work this way? Thanks in advance for your time.



  • Also, I’ve encountered another issue when using word wrap. If the file is long enough to require a scroll bar and my view is not at the top of the file, any time I switch to a different window, then come back to NP++, the view automatically scrolls to the very top of the file, and does so rather slowly. For example, when the file is over 15,000 lines, it takes about 15 seconds to finish scrolling to the top before I am able to start scrolling back down to search for my location again.

    This only occurs when word wrap is on, and only started occurring when I updated to the new version (6.7.9.2). Since it just started occurring after I updated the program, I’m assuming that it is either a new default setting that I am unable to find and disable, or a new bug introduced in this version.

    I find this new behavior to be quite annoying and would like to disable it. If it is a default setting change, where is the setting to turn off the automatic scrolling to the top of the file? If it is a bug introduced in this version, what is the easiest method I could use to revert the program to the previous version in which this issue did not occur?


Log in to reply