Return auto indent to old settings



  • Hi

    I have used Notepad++ for quite a while, mainly for php. Recently upgraded my PC so installed a fresh version.

    However the way auto indent works has changed.

    Previously if I entered a curly bracket and pressed return it went to the next line but didn’t indent any further. I manually pressed tab, and following lines afterwards would be indented in line with my manual tab.

    However it has now changed that when I enter a curly bracket and press return it automatically indents an extra tab. Which annoys the hell out of me!

    I have played with the settings (I have already turned off the auto complete of curly brackets), but the only option that seems to affect the indenting is to turn auto indent off. But then on any fresh line I am back to the far left and need to manually do all the indentation.

    Is there a setting to just indent to the same amount as I had manually indented previously without trying to add an extra indent for me?

    All the best

    K



  • I have a similar problem with the new Auto Indent feature with curly braces. If I have a line width a curly brace at the end of it, then on the next line I want to put the matching curly brace somewhere other than at the start of the line above N++ automatically moves the curly brace where it thinks it should be at the start of the line above.

    This is different than how it behaved before and is completely unnecessary. I will control where I put the characters, the auto indent feature should only move the cursor, not move any characters I have typed.

    I know disabling removes this but then when I press enter I’m all the way at the left hand side of the screen again. Please give us the option to change it back to the old way. It was working fine before.



  • I too call for either the return to the old indent behaviour or at least a way to get rid of the so-called ‘smart’ indent - it’s a big time annoyance to me.
    I’ve used N++ since at least version 3.5 (that’s the oldest installer I could find in the backups), always upgrading as soon as a newer version came out. Now I’ve reversed to version 6.6.9 and given up on upgrades just to get rid of this. I just can’t understand why forcing somebody else’s coding style upon my code is supposed to be ‘smart’…
    Pretty please?



  • Hello,

    same issue here. Please let the user chose the desired settings.
    The current behavior deranges me. The old one was user friendly and helped me a lot!
    Thank you!



    • return to old auto indent settings

Log in to reply