Windows 10 Shell Context Menu Error



  • Is anyone else having a problem with Windows 10 shell execute for editing a file in notepad++?

    I just installed a fresh copy of Windows 10 Pro x64 and notepad++ and this is what i get:

    http://screencast.com/t/G0LrjzpCKR8p

    Any help would be greatly appreciated.



  • I handled this with an old tweak that can be adapted to work with any executable.

    Create a text file with a “.reg” extension and add the content below. Then click on this file and click OK to the consent prompts. Notepad++ shows up in your menu immediately.

    When done this way, it can be used inappropriately (like trying to edit an executable binary file).

    === Registry file content below this line ===

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT*\shell\Notepad++]

    [HKEY_CLASSES_ROOT*\shell\Notepad++\command]
    @="“C:\Program Files (x86)\Notepad++\notepad++.exe” “%1"”



  • I am having this same error and after I run the reg file and use the context menu it crashes explorer. It also doesn’t look like it added the registry entries. Also running Windows 10 Pro x64.



  • Hi All,

    Error http://screencast.com/t/G0LrjzpCKR8p

    Navigate to C:\Program Files (x86)\Notepad++ Right mouse click the Notpad++.exe file click properties & under the compatability Tab UN-TICK the run the program as administrator box DONE.

    Regards



  • Create a text file with an extension “.reg” and add the content below. Then, double-click this file and OK to messages consent. Notepad ++ will appear on the menu immediately if not need to restart the computer.

    To add a section to the context menu
    === Registry file content below this line ===

    Windows Registry Editor Version 5.00

    [HKEY_CLASSES_ROOT*\shell\Notepad++]

    [HKEY_CLASSES_ROOT*\shell\Notepad++\command]
    @=“C:\Program Files (x86)\Notepad++\notepad++.exe %1”

    Removes the old context menu
    === Registry file content below this line ===

    Windows Registry Editor Version 5.00

    [-HKEY_CLASSES_ROOT*\shellex\ContextMenuHandlers\ANotepad++64]
    [-HKEY_CLASSES_ROOT\CLSID{B298D29A-A6ED-11DE-BA8C-A68E55D89593}]

    Run Notepad++ with administrator privileges
    === Registry file content below this line ===

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers]
    “C:\Program Files\Notepad++\notepad++.exe”=“RUNASADMIN”
    “C:\Program Files (x86)\Notepad++\notepad++.exe”=“RUNASADMIN”



  • @John-Evans This worked for me.

    Oddly, I had right-clicked and selected Properties and then Advanced and ticked the “Run as Administrator” option there as well as ticking the compatibility “Run As Administrator” option.

    deselecting the latter makes it function normally again!

    Thanks John. :-)



  • Don’t use this registy trick. It looks ugly. Use “Save As Admin” plugin, instead. It works fine even at windows 10 and previous versions.