national characters missing on windows 8.1



  • I have a file with Central Europea Mac encoding which contains Lithuanian letters. Some national letters are not shown in the editor for example word is shown as “tkm” while it should be shown as “t˜km˜” (because I am viewing mac file with a different encoding on the windows I cannot see the correct characters anyway, but I should see some wrong characters. On the windows xp the same version of Notepad++ does show all the letters. I have checked the same file with another editor it does show the “t˜km˜”.
    I cannot use notepad++ anymore :(



  • Which version are you using? For some versions now the default font has been Source Code Pro, maybe it doesn’t support these Lithuanian characters. Try the absolute latest version (6.8.2) which removes Source Code Pro.

    Have you tried changing the character set manually? See Encoding -> Character sets -> Baltic.

    A while back N++ started trying to autodetect the character encoding, it might work better if you switch this off (Settings -> Preferences -> Misc -> Autodetect character encoding).


Log in to reply