Chris McGrath Homepage: http://codealignment.com Latest update: V12



  • One of my favorite plug-ins has suddenly stopped working. When I updated to NPP v6.8.2 this plug-in which had worked for a long time suddenly stopped working. I uninstalled it and when reinstalling it it almost immediately get an install error. I reverted to NPP v6.8 and still no luck.

    Anyone else experiencing this?

    Windows XP
    NPP v6.8 and NPP v6.8.2
    Plug-in manager 1.3.5.0
    Code Alignment v12: Chris McGrath http://codealignment.com V12



  • Define “stopped working” and “install error”.



  • Apologies for the previous lack of clear information before. Actually I should have said that a re-installation of this plug-in fails as below.

    Install error:

    • In Plug-In Manager>Available tab Code Alignment is checked.
    • Press the “Install” button.
    • Downloading dialog appears. The download progress starts to fill.
    • Installation Error message box pops up saying “Installation of Code alignment failed”.

    In an attempt to get this function back, I uninstalled NPP v6.8.2 and reinstalled it. I made sure the Code Align plug-in was erased from the NPP folder before the reinstall. Other plug-ins seem to install OK.

    Stopped Working:
    So I guess “stopped working” was the fact that it could not be re-installed. I have even uninstalled all and reverted to NPP v6.8 and the same thing happens. Weird. You’d think that completely uninstalling NPP and also the folder would fix it on the next install of NPP.



  • If you uninstall N++ make sure the entire folder is removed from your Program Files directory. Also check your %APPDATA%/Notepad++ directory as some configuration files are also stored there. The Notepad++ uninstaller is not aware of any files plugins may have created so it is best to make sure everything is deleted.



  • I tried getting rid of the N++ ApData. Unfortunately no joy there. I’ve tried getting rid of everything and reinstalling. Maybe it’s my machine or WinXP which I’m stuck with here at work. (I have no problem with this at home with Win7-x64.

    Don’t know what to say. I really like the alignment functions for refactoring a lot of code.
    Thanks for looking at this however.

    Oh— is there anything that could be stuck in the registry do you think?



  • OK, I found it. The plugin download URL has a misspelling in it. It cannot access the Github file. The letter “c” was left out of cpmcgrath.

    Incorrect URL: https://github.com/cpmgrath/codealignment

    Correct URL: https://github.com/cpmcgrath/codealignment

    Can’t fix it from here, but maybe I can manually access the plugin through GitHub.


Log in to reply