Notepad++ 7.7.1 won't default to .txt when saving



  • It is all in the title line: the version I have keeps saving my text files to “all extensions”, which give me no extension at all. When I create a file, or open a .txt file, and choose “Save as” or “save”, I would like it to use .txt. A file with no extension is pretty useless.

    I went to Settings->Preferences->File Associations and made .txt a registered extension, but when I close Notepad++ and open it again, the registered extension .txt is no longer there.



  • @Anna-Naden said:

    It is all in the title line

    No, it isn’t. One can only make some guesses from experience on what exactly your meaning is.

    Pay attention now, if you want a file called test.txt, when you are prompted to give it a filename, type t e s t . t x t and then press the Save button. There is no other way.



  • @Anna-Naden

    as @Alan-Kilborn said, if you provided it with the extension you should get a file saved with that extension.
    But what I ASSUME you want to have is a different view in the file save dialog, correct? If so, the setting is Settings->Preferences->Default Directory->use new style …



  • @Alan-Kilborn you are everything I hate.



  • The solution is simple.

    1. Search for Notepad ++ by pressing the Windows button
    2. Right-click on Notepad ++ and Run as administrator
    3. Notepad ++ Run as administrator
    4. Navigate to the path Settings -> Preferences -> Default Directory
    5. Uncheck the “Use new style dialog (without file extension feature & Unix style path capacity)”

    Once you make this change in the Notepad ++ preference, the Save As dialog will have .txt extension by default as shown below

    Source:
    https://techsupportwhale.com/set-default-extension-while-saving-in-notepad-plus-plus/



  • @Luis-R just had to create an account to say THANKS! I was starting to feel I’d lost my mind; kept finding all these files I’d saved with no extension. This setting is why. (Don’t remember ever enabling it; wonder if I downloaded a Notepad++ update that turned it on?) Anyway, thanks!



  • @Josh-Mayfield

    Better yet, wait for the 7.8.7 release which will drop imminently and that fixes this behavior using the New style dialogue.

    Cheers.



  • @Alan-Kilborn In English, “default” means that it gets selected or populated automatically, without the user having to do it manually. Once you learn its meaning, it becomes easy to understand the title without having to guess. Replying boldly without understanding what the other user has posted comes off as very patronising.

    @Michael-Vincent Updated to Notepad++ v7.8.7 and I can confirm that the bug has been fixed as you said.


Log in to reply